"Add New" prompt desappears after unlocking the screen

1. What is the problem? Be very detailed.
When I lock the screen before adding a new group, when I unlock the phone I get a Blanck page, I only can go back and then forward to add the new item. The best would be to get the prompt visible after unlocking the phone and my colleagues seem to say that it was the case before.

2. What app or server are you using and on what device and operating system? Include version numbers.
Collect 1.23.3 ANdroid 6.0.1 Samsung Galaxy S5
3. What you have you tried to fix the problem?
4. What steps can we take to reproduce the problem?
Go to a prompt for a new group, lock the phone and unlock it.
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Screen before locking :

Screen unlocked :

1 Like

@mathieubossaert hey :wave:

Tried the same steps and saw the same thing - I also found the responsible line in the code. This does seem like it's confusing and I personally don't see a reason for it to behave that way. I'm going to check on whether we have any existing bugs for this but otherwise I'll post an issue on Github and link it here.

1 Like

@mathieubossaert I've filed an issue here. Would you be able to share the fom you're using? It's definitely better to be able to test/design fixes around real life forms than contrived ones.

Thanks a lot Callum !
Here is the big form...
sicen_2019.xlsx (20.4 KB)
And its medias (truncated to few lines).
sicen_2019-media.zip (46.7 KB)
You can try "Abortiporus fractipes" for fungi, "acrocephalus scirpaceus" for Animalia and "Abies alba" for plantae.