Aggregate not starting

Hello there,
I installed ODK-Aggregate-v2.0.5 with apache-tomcat-9.0.37 on Ubuntu 16.04 server. But, the ODKAggregate cannot start,

the error pop-up at the top is 'FAIL - Application at context path [/ODKAggregate] could not be started'
And the catalina log file is here.
catalina.2020-08-31.zip (7.4 KB)
So, please help me

Regards!

The errors in your log suggest there is something wrong with your Tomcat manager config. Fix that first and I bet Aggregate will start working.

31-Aug-2020 10:39:17.784 SEVERE [Catalina-utility-2] org.apache.tomcat.util.digester.Digester.fatalError Parse fatal error at line [20] column [1]
	org.xml.sax.SAXParseException; systemId: file:///opt/tomcat/webapps/manager/META-INF/context.xml; lineNumber: 20; columnNumber: 1; Element type "Valve" must be followed by either attribute specifications, ">" or "/>".

Yanokwa,
Thank you for your timely response and kind support. I tried to correct the configuration based on your comment. But, stil the problem is there. Now, even the tomcat manager is not accessible.
Here is today's log file

catalina.2020-09-01.zip (7.6 KB)

Thanks!
Regards!

Hello there,

Please help me about ODKAggregate,
It couldn't started yet. I have tried many ways to solve the problem.

  1. I have run the installer.run file and give the path (tomcat/webapps).
  2. It automatically deploy the .war file to tomcat server.
  3. I have edit set the JAVA_HOME, create the database based on the generated .sql file.
  4. and so many things

But, I can't fix the problem.
when I click the ODKAggregate on tomcat page it appears look like this