Aggregate VM connectivity issues

1. What is the problem? Be very detailed.
The issue is with the connectivity to Aggregate VM. The VM is running on Oracle VirtualBox. When installing the VM I have followed the steps mentioned in the setting up documentation in
I have successfully setup and configured the VM. Initially I was able to connect to the Aggregate VM

  • from the browser on host computer,
  • from the Briefcase,
  • was able to get blank forms and send finalazed forms using ODK Collect on the tab.

After about 2 days of usage the connectivity was intermittent, ie. the connection to Aggregate VM was working sometimes but some other times cannot able to connect. When I used the IP address that is shown by the AggregateVM, the browser shows the message "This site can't be reached" "ERR_CONNECTION_TIMED_OUT". When I used the alternate IP, the browser shows the "Awaiting Redirect" and throws an "ERR_CONNECTION_TIMED_OUT" error. In the Network tab of the Chrome browser Inspect, the status shows Aggregate.html loading as failed.

I tried all the Aggregate VM versions starting from version 1.7.0 upto 2.0.0, but the connectivity issue remains the same with all the versions.

2. What app or server are you using and on what device and operating system? Include version numbers.
-Core i5 desktop with Windows 10 Pro
-AggregateVM 2.0.0 on VirtualBox
-ODK Collect v1.19.0

3. What you have you tried to fix the problem?
After going through the support forum with the connectivity issues topics some of the following reasons were mentioned
-local netork setup
-internet connectivity
-VM not configured properly

To avoid all the complications I used only one desktop with a dedicated wifi hotspot but still I could not connect to the VM.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Thanks for providing all this great detail, @gurudath!

My guess is that when your connection was intermittent, your upstream router changed your IP address and the VM didn't pick that change up.

Typically a reboot and setting the FQDN (probably to in this case) as described at should work. Have you tried that?

Hi, I have the same issue and I had set the setting the FQDN and I have tried rebooting multiple times.