App keeps stopping error ODK collect

I recently updated ODK Collect from the play store and the recent update will not start. It displays an error "App keeps stopping" and suggests I send a feedback. I realized that a while back I had joined the beta and forgot about it. I tried unjoining the beta as well as uninstalling and reinstalling the app but when I check the app info on my phone it still says I'm using the beta version and the app still wouldn't work.

I'm using a Motorola one power device running stock Android pie. ODK Collect Version v1.23.0-beta.1 is the version I updated to and the app keeps crashing.

I've tried downloading the .apk of the latest stable version of the app v1.22.4 from GitHub but that won't even install.

Hmm that's strange that you weren't able to leave the beta. I have found the Play Store's leaving/joing process can be awkward. Could you try the following:

  1. Uninstall ODK Collect
  2. Hit the leave beta button in the ODK Collect Play Store page
  3. Close and reopen the play store and navigate to the ODK Collect page - check you can join the beta again (to make sure you've definitely left)
  4. Reinstall and open the app - it should be version 1.22.4.

I'm interested to see if the latest version (1.22.4) is also causing you problems or not.


You might also try to use a different account, since it's recommended to use a different account for Beta versions


Thanks for the reply guys! Problem fixed! It seems there was a guest user account on the device and odk collect was installed on that account as well. It seemed unusual that the app would install within a second, after I uninstalled and deleted all related files, considering my slow net speed. I uninstalled the app from the guest account as well and reinstalled the app using the .apk file n it works just fine now.
Although I'm thinking, since you suggest I use a different account for the beta, how did the app in the guest account update to a beta? I'm very sure the account has been inactive for a while.