ArMeasure external app can't be launched by Collect on Android 11+

1. What is the issue? Please be detailed.
I have a new smartphone that is capable of augmented reality. I would like to open an app from ODK that allows you to measure widths and take a photo of them.
I tried the instructions for external apps and unfortunately failed. In appearance I pasted the android file path as
The app I want to access is called AR Measure ( I don't know if it's because I tried this as Type=Image or the app itself doesn't allow access. It would be enough for me if I could open the app from ODK. Of course, if I could get the photo file back from it, that would be even better (but I'd be happy just opening the app). I have attached my xlsx file. It would be really great if someone could help me with this or give me an advice to fix the problem.

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?
everything whats possible for me :wink:

4. Upload any test forms or screenshots below.
ODK_externApp.xlsx (10.1 KB)

Hi @Dominik1
I don't know if that app can be used to pass an image back to ODK but it should be possible to open it at least. I've just tested your form and it seems to work fro me. The appearance can just be ex:com.peace.ArMeasure() but your version should work too.
What ODK Collect version are you using? And what device do you have?

The newest beta (today Update)

Maybe the problem is with the special characters (for example ' )? I'm using the German version of Excel

Mein Smartphone ist das Samsung Galaxy S21 Design

and did you see any error or what exactly happens after clicking on the button that should open the app?

Excuse me. I completely forgot to write that.
The desired app is not available...

But the app is available

Could you also attach the xml form you used?

Was generated via

ODK_externApp.xml (956 Bytes)

Hmm interesting it works on my device. Could you maybe try starting other external apps like ODK Counter? Here is a form

It works with the Counterapp.

I would use another app for AR measurements. I just can't find one that 1. costs nothing, 2. takes photos.

Except for an app from Samsung
"Quick Measure".
But I can't find them in the file folders on Android.

Do you have other devices to test?

Yes, I tested it with Samsung M30
Maybe its a Problem by Samsung

If I may ask, which device did you use for the test?

I tested it only on an emulator. It's not available on the real device I have. But I've asked the QA team to check their devices and it seems like they have the same problem. Could you confirm @Szymon_Rujner I'm not able to tell what's wrong without testing that device... I will meet @Szymon_Rujner sooner or later so then I will try to take a look at this issue.

@Grzesiek2010 @Dominik1
Yes I can confirm that I was able to reproduce this issue on Pixel 3a device.

Ok, thank you very much.
I hope you get this very special problem solved. That would help me a lot (and the improvement of cycling as well)

@Grzesiek2010 got a fix in for v2022.2.3 which is now rolling out. Thanks for helping us troubleshoot! :biking_man:

Dear ODK Team.
What shall I say?
You are simply the best. Wish you all a nice day.

Just tested. It works.
Best regards,

1 Like