Briefcase - connection refused

What is the problem? Please be detailed.

I'm trying to pull forms from Aggregate with Briefcase, but I get the error "Connection refused". Oddly, Briefcase version 1.10.0 works fine (I was able to pull a form with 6 instances), and the connection error happens with versions 1.11 through 1.14. Could this be a bug? Or is it a proxy related issue?

What ODK tool and version are you using? And on what device and operating system version?

I tried Briefcase versions 1.10 through 1.14.
Aggregate is installed in Google App Engine, and I can login in the browser and view my forms.
OS is Windows, java version is 8.201 from Oracle.
I'm behind a proxy, but that doesn't seem to be the problem (I think).

What steps can we take to reproduce the problem?

  • I tried different versions of Briefcase and only 1.10.0 worked. All posterior versions don't connect.
  • The same error occurs if I type a random URL endind with (e.g., or if I type the wrong credentials.
  • This is the log:

2019-02-19 11:40:57,408 [main] ERROR org.opendatakit.briefcase.Launcher - Error
org.opendatakit.briefcase.reused.http.HttpException: Connection refused
at org.opendatakit.briefcase.reused.http.CommonsHttp.uncheckedExecute(
at org.opendatakit.briefcase.reused.http.CommonsHttp.execute(
at org.opendatakit.briefcase.reused.RemoteServer.testPull(
at org.opendatakit.briefcase.operations.PullFormFromAggregate.pullFormFromAggregate(
at org.opendatakit.briefcase.operations.PullFormFromAggregate.lambda$static$0(
at org.opendatakit.common.cli.Cli.lambda$run$4(
at java.lang.Iterable.forEach(Unknown Source)
at org.opendatakit.briefcase.Launcher.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(

  • If I type a random domain name, a different error appears (e.g. --> This makes me think that the problem is not the proxy, but I may be wrong.
  • I used wireshark to analyse the packets, here's what I get:

My guess is that this is a proxy issue. Have you tried on a different connection? Alternatively, you can send me new form manager credentials to and I'm glad to try to reproduce the problem.