Briefcase not pulling data

What is the problem? Please be detailed.

What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Dear ODK users and support team,

I am trying to pull the data from the ODK folder which I copied from the tablet. I used ODK briefcase v1.8.0 and chose Custom path to ODK Directory. Unfortunately, I am not able to see any forms to pull. I have also installed Java 8 in the system.
Any help will be greatly appreciated.


Hello Amayuga, if you've passed all these steps :

Ensure that all filled-in forms on ODK Collect are finalized. If they are not finalized, you should either delete them via ODK Collect's 'Delete Saved Form' button or make a back-up copy of the '/sdcard/odk' directory on your device, delete the incomplete forms in ODK Collect. Source: here.
If this doesn't manage it, explain me in details what you've donne. I'm a starter like.


Hi Abdoul,

I already did all the steps based on the instructions from here: and still, I am not able to pull out the data. Is there anything I am missing in here?

Thank you,

OK, is it when you go to "choose file" that you won't see it?

yeah, I couldn't see any data on it. My ODK folders aren't empty and contains forms, instances, and metadata.

Sorry for being unable to help, I'm a starter too. may be @LN or @yanokwa could.

Are you able to provide some screenshots showing the folder structure that contains your data? And also the settings you are inputting into Briefcase?

1 Like

Hi danbjoseph,

Here are the screenshots for the folder structure and the settings for the Briefcase. Kindly take a look at it and let me know if there's anything missing.

Thanks, ODK SC.docx (508.5 KB)

Hello, it still not working?

1 Like

This is very odd. @Amayuga, I don't know how sensitive your data is, but if it's not sensitive, can you please zip up the odk folder and send it to me? I will send you a PM with a link.

3 posts were split to a new topic: Briefcase unable to load from configured source

Having the same problem pulling data. Can you assist? Find link to zipped ODK folder?

Hi @zachzach13! I've been able to pull and export your forms using Briefcase v1.16.2. Could you try this?

You can get the latest Briefcase at

Yaaay!! you are the best. Its pulling data now. What was i doing wrong? was it the Briefcase version?

Yes :slight_smile: Newer Briefcase release come with newer JavaRosa versions that expand xforms compatibility and features :slight_smile: