Can not upload form to Aggregate server

1. What is the problem? Be very detailed.
I can't upload form through ODK Build to ODK Aggregate server.

2. What app or server are you using and on what device and operating system? Include version numbers.
Windows 10

3. What you have you tried to fix the problem?
Several other usernames and passwords. Delete and again create odk_setup database.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.odk

Hi @Franjo_Milas
welcome to the forum! Please introduce yourself here!

do you have both ODK Aggergate and ODK Build on your machine? I guess you are using the online one if so you can't pass localhost address because it doesn't point to your machine. You need to use your IP address.

Hi @Grzesiek2010, thank you for your answer.

Yes, that was in online ODK Build, but even though I have put my IP address it doesn't work. I have also tried through offline ODK Build (I haven't install it, the application can be run in a folder after extracting?), with localhost address and again nothing. I relatively new in this, I have followed all steps of pre installation processes and I'm 99% sure that I did everything good. Do you have advise!


Can you access your server using that IP (from ODK Collect or just a browser) or maybe it works only when you are connected to the same wifi and you use localhost? If you can't probably you didn't configure it.
It's point 4 from