Cannot complete installation of ODK Aggregate in app engine

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting some
error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&
401 Unauthorized
Must authenticate first.
"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

Is there a more informative error farther down? Recently with
authentication problems I saw a "incorrect password" or something message.

With an app specific password on an account with two factor authentication
I had no problems. On an account without two factor auth I had to go to
security.google.com and toggle a switch to "allow sign in from less secure
apps" or something like that, then run the installer, then turn the toggle
off again.

ยทยทยท On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN wrote:

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting some
error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&
401 Unauthorized
Must authenticate first.
"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

1 Like

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this
link https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when the
people above faced the problem. Now they permanently disabled from April
13th.
In a nutshell, Move to OAuth.

Hi all,

I've been struggling with the same problem for hours today...
Concretely what does it mean? Is it impossible to install odk aggregate on
google app engine for the moment?

Thanks!

Cรฉline

ยทยทยท Le mercredi 9 mars 2016 06:51:26 UTC+1, A.N.M AL-IMRAN a รฉcrit : > > Hi All, > > I am trying to install ODK Aggregate on Google app engine and getting some > error message: > > "WARNING: Error posting to URL: > https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment& > 401 Unauthorized > Must authenticate first. > " > I am using app specific password still cannot resolve the issue. Looking > forward for your help urgently, need to deploy my soon. > > Thanks >

Thanks to the team for the fast update to 1.4.8, I can confirm that I managed to download and install on appengine and that the 'token' method worked fine for me. Im running a new instance for a new client just as before.
Cheers, Roger 18 April 2016

ยทยทยท On Wednesday, March 9, 2016 at 6:51:26 AM UTC+1, A.N.M AL-IMRAN wrote: > Hi All, > > > I am trying to install ODK Aggregate on Google app engine and getting some error message: > > > "WARNING: Error posting to URL: https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&401 Unauthorized > Must authenticate first. > > " > I am using app specific password still cannot resolve the issue. Looking forward for your help urgently, need to deploy my soon. > > > Thanks

Thanks Sam,

Yes, actually the complete error message is as the following:
WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/getresourcelimits?app_id=site-assessment&version=1&
401 Unauthorized
Must authenticate first.
This is try #0
java.lang.RuntimeException: Bad authentication response: 404 Not Found
Unable to update app: Bad authentication response: 404 Not Found

What do I need to consider during installing my jama. last two days I have
installed and uninstalled java at-least 20 times. Note: few times I have
installed it in a different drive other that C.

Your advice will be appreciated.

Thanks
Imran

A N M AL IMRAN (Imran)
Brossard, QC
Canada
Cell: +1 (438) 501 3576

ยทยทยท On 9 March 2016 at 07:29, Sam Sudar wrote:

Is there a more informative error farther down? Recently with
authentication problems I saw a "incorrect password" or something message.

With an app specific password on an account with two factor authentication
I had no problems. On an account without two factor auth I had to go to
security.google.com and toggle a switch to "allow sign in from less
secure apps" or something like that, then run the installer, then turn the
toggle off again.

On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN imran3may@gmail.com wrote:

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting
some error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&
401 Unauthorized
Must authenticate first.
"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'm not positive, but that doesn't sound like a Java problem. 404 Is an
HTTP error saying it cannot find the URL. Are you on mac or windows?

Have you already created a new app engine project? Are you entering the
correct project ID when prompted in the Aggregate installer? When you go to
https://console.developers.google.com/, you should see a project you've
created to where you're going to upload the server. In one of the boxes on
my own page I see "Project Name: " and "ID: ".
Have you done this step? Are you entering the project id shown next to ID?

ยทยทยท On Wed, Mar 9, 2016 at 9:43 AM, A.N.M AL-IMRAN wrote:

Thanks Sam,

Yes, actually the complete error message is as the following:
WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/getresourcelimits?app_id=site-assessment&version=1&
401 Unauthorized
Must authenticate first.
This is try #0
java.lang.RuntimeException: Bad authentication response: 404 Not Found
Unable to update app: Bad authentication response: 404 Not Found

What do I need to consider during installing my jama. last two days I have
installed and uninstalled java at-least 20 times. Note: few times I have
installed it in a different drive other that C.

Your advice will be appreciated.

Thanks
Imran

A N M AL IMRAN (Imran)
Brossard, QC
Canada
Cell: +1 (438) 501 3576

On 9 March 2016 at 07:29, Sam Sudar sudar.sam@gmail.com wrote:

Is there a more informative error farther down? Recently with
authentication problems I saw a "incorrect password" or something message.

With an app specific password on an account with two factor
authentication I had no problems. On an account without two factor auth I
had to go to security.google.com and toggle a switch to "allow sign in
from less secure apps" or something like that, then run the installer, then
turn the toggle off again.

On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN imran3may@gmail.com wrote:

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting
some error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&
401 Unauthorized
Must authenticate first.
"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Is there any instructions available for installation on OAuth? If anyone
already did that, please share it here in detail. Thanks

ยทยทยท On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.bodapati@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when
the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Correct.

We will have an ODK Aggregate 1.4.8 installer available tomorrow.

Once that is released, if you ever do need to revert to an earlier (1.4.7
or earlier) release, there is a work-around to do that (


)

ยทยทยท On Thu, Apr 14, 2016 at 4:14 PM, Celine Roman wrote:

Hi all,

I've been struggling with the same problem for hours today...
Concretely what does it mean? Is it impossible to install odk aggregate on
google app engine for the moment?

Thanks!

Cรฉline

Le mercredi 9 mars 2016 06:51:26 UTC+1, A.N.M AL-IMRAN a รฉcrit :

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting
some error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&
401 Unauthorized
Must authenticate first.
"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks to the developers for this quick fix - everything just worked fine for me. Thanks to the community for providing questions and answers so I could stop struggling!

Dear Sam,

Thanks, I appreciate your support, The issue has been resolved. I contacted
Google app engine team, and they informed me that, they had a service
disruption, which was not allowing me to upload ODK to my appengine. Now it
is perfectly up and running. Learning from this problem is, we all need to
keep in mind that we need to think of issues on cloud hosting end.

Thank you once again Sam

Imran

ยทยทยท On Wednesday, March 9, 2016 at 3:47:24 PM UTC-5, Sam Sudar wrote: > > I'm not positive, but that doesn't sound like a Java problem. 404 Is an > HTTP error saying it cannot find the URL. Are you on mac or windows? > > Have you already created a new app engine project? Are you entering the > correct project ID when prompted in the Aggregate installer? When you go to > https://console.developers.google.com/, you should see a project you've > created to where you're going to upload the server. In one of the boxes on > my own page I see "Project Name: " and "ID: ". > Have you done this step? Are you entering the project id shown next to ID? > > On Wed, Mar 9, 2016 at 9:43 AM, A.N.M AL-IMRAN <imra...@gmail.com > wrote: > >> Thanks Sam, >> >> Yes, actually the complete error message is as the following: >> WARNING: Error posting to URL: >> https://appengine.google.com/api/appversion/getresourcelimits?app_id=site-assessment&version=1& >> 401 Unauthorized >> Must authenticate first. >> This is try #0 >> java.lang.RuntimeException: Bad authentication response: 404 Not Found >> Unable to update app: Bad authentication response: 404 Not Found >> >> What do I need to consider during installing my jama. last two days I >> have installed and uninstalled java at-least 20 times. Note: few times I >> have installed it in a different drive other that C. >> >> Your advice will be appreciated. >> >> Thanks >> Imran >> >> >> A N M AL IMRAN (Imran) >> Brossard, QC >> Canada >> Cell: +1 (438) 501 3576 >> >> On 9 March 2016 at 07:29, Sam Sudar <suda...@gmail.com > wrote: >> >>> Is there a more informative error farther down? Recently with >>> authentication problems I saw a "incorrect password" or something message. >>> >>> With an app specific password on an account with two factor >>> authentication I had no problems. On an account without two factor auth I >>> had to go to security.google.com and toggle a switch to "allow sign in >>> from less secure apps" or something like that, then run the installer, then >>> turn the toggle off again. >>> >>> On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN <imra...@gmail.com > wrote: >>> >>>> Hi All, >>>> >>>> I am trying to install ODK Aggregate on Google app engine and getting >>>> some error message: >>>> >>>> "WARNING: Error posting to URL: >>>> https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment& >>>> 401 Unauthorized >>>> Must authenticate first. >>>> " >>>> I am using app specific password still cannot resolve the issue. >>>> Looking forward for your help urgently, need to deploy my soon. >>>> >>>> Thanks >>>> >>>> -- >>>> -- >>>> Post: opend...@googlegroups.com >>>> Unsubscribe: opendatakit...@googlegroups.com >>>> Options: http://groups.google.com/group/opendatakit?hl=en >>>> >>>> --- >>>> You received this message because you are subscribed to the Google >>>> Groups "ODK Community" group. >>>> To unsubscribe from this group and stop receiving emails from it, send >>>> an email to opendatakit...@googlegroups.com . >>>> For more options, visit https://groups.google.com/d/optout. >>>> >>> -- >>> -- >>> Post: opend...@googlegroups.com >>> Unsubscribe: opendatakit...@googlegroups.com >>> Options: http://groups.google.com/group/opendatakit?hl=en >>> >>> --- >>> You received this message because you are subscribed to a topic in the >>> Google Groups "ODK Community" group. >>> To unsubscribe from this topic, visit >>> https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe. >>> To unsubscribe from this group and all its topics, send an email to >>> opendatakit...@googlegroups.com . >>> For more options, visit https://groups.google.com/d/optout. >>> >> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekassouf@timelesstech.com

Please consider the environment before printing this mail note.

ยทยทยท On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN wrote:

Is there any instructions available for installation on OAuth? If anyone
already did that, please share it here in detail. Thanks
On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.bodapati@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when
the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Imran & Sam,

I am stuck here as well with this error.
I am running the mvn gae:deploy command (mac terminal)

java.lang.RuntimeException: Bad authentication response: 404 Not Found
Unable to update app: Bad authentication response: 404 Not Found
Please see the logs [/var/folders/v7/3ssx8xvs3n92yqcxyznmxxr80000gn/T/appcfg1204996708125139944.log] for further information.

Who can I contact to resolve this issue?

Thanks!

Elie Kassouf

ยทยทยท On Thursday, March 10, 2016 at 10:35:50 AM UTC-4, A.N.M AL-IMRAN wrote: > Dear Sam, > > > Thanks, I appreciate your support, The issue has been resolved. I contacted Google app engine team, and they informed me that, they had a service disruption, which was not allowing me to upload ODK to my appengine. Now it is perfectly up and running. Learning from this problem is, we all need to keep in mind that we need to think of issues on cloud hosting end. > > > Thank you once again Sam > > > Imran > > On Wednesday, March 9, 2016 at 3:47:24 PM UTC-5, Sam Sudar wrote: > I'm not positive, but that doesn't sound like a Java problem. 404 Is an HTTP error saying it cannot find the URL. Are you on mac or windows? > > > Have you already created a new app engine project? Are you entering the correct project ID when prompted in the Aggregate installer? When you go to https://console.developers.google.com/, you should see a project you've created to where you're going to upload the server. In one of the boxes on my own page I see "Project Name: " and "ID: ". Have you done this step? Are you entering the project id shown next to ID? > > > On Wed, Mar 9, 2016 at 9:43 AM, A.N.M AL-IMRAN wrote: > > Thanks Sam, > > > Yes, actually the complete error message is as the following: > WARNING: Error posting to URL: > https://appengine.google.com/api/appversion/getresourcelimits?app_id=site-assessment&version=1& > 401 > Unauthorized > Must authenticate first. > This is try > #0 > java.lang.RuntimeException: Bad authentication response: 404 Not > Found > Unable to update app: Bad authentication response: 404 Not Found > > > > What do I need to consider during installing my jama. last two days I have installed and uninstalled java at-least 20 times. Note: few times I have installed it in a different drive other that C. > > > Your advice will be appreciated. > > > Thanks > Imran > > > > > > > > > > > > > > > > > A N M AL IMRAN (Imran) > > > Brossard, QC > Canada > Cell: +1 (438) 501 3576 > > > > > On 9 March 2016 at 07:29, Sam Sudar wrote: > > > > Is there a more informative error farther down? Recently with authentication problems I saw a "incorrect password" or something message. > > With an app specific password on an account with two factor authentication I had no problems. On an account without two factor auth I had to go to security.google.com and toggle a switch to "allow sign in from less secure apps" or something like that, then run the installer, then turn the toggle off again. > > > > On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN wrote: > > Hi All, > > > I am trying to install ODK Aggregate on Google app engine and getting some error message: > > > "WARNING: Error posting to URL: https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&401 Unauthorized > Must authenticate first. > > " > I am using app specific password still cannot resolve the issue. Looking forward for your help urgently, need to deploy my soon. > > > Thanks > > > > > -- > > -- > > Post: opend...@googlegroups.com > > Unsubscribe: opendatakit...@googlegroups.com > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > --- > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com. > > For more options, visit https://groups.google.com/d/optout. > > > > > > > > > -- > > -- > > Post: opend...@googlegroups.com > > Unsubscribe: opendatakit...@googlegroups.com > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > --- > > You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group. > > To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe. > > To unsubscribe from this group and all its topics, send an email to opendatakit...@googlegroups.com. > > For more options, visit https://groups.google.com/d/optout. > > > > > > > > > > -- > > -- > > Post: opend...@googlegroups.com > > Unsubscribe: opendatakit...@googlegroups.com > > Options: http://groups.google.com/group/opendatakit?hl=en > > > > --- > > You received this message because you are subscribed to the Google Groups "ODK Community" group. > > To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit...@googlegroups.com. > > For more options, visit https://groups.google.com/d/optout.

Hello Friends, Thanks a lot to Elie. However, I would request to the
experts in this group to volunteer to layout the sequences of installing
ODK using in a more collaboratively for those use ODK for years for their
work and do not have much technical knowledge, but with instructions they
will be able to manage. I believe many people got stuck at this point due
to this change. Since the previous installation process was pretty straight
forward. ODK experts did not updated the installation procedure using OAuth
2 yet. Thanks

ยทยทยท On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote: > > > https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client > > > > Elie G Kassouf > Mobile Developer > Timeless Technologies > > ekas...@timelesstech.com > > > > *Please consider the environment before printing this mail note.* > > On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN <imra...@gmail.com > wrote: > >> Is there any instructions available for installation on OAuth? If anyone >> already did that, please share it here in detail. Thanks >> On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.b...@enterprisenube.com > wrote: >> >>> Hello guys, >>> >>> Root cause of this problem is that Google App Engine turned off client >>> login from April 13th. Read the last paragraph in this link >>> https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20 >>> >>> On March 8th Google tested it by turning it off for 1 day which is when >>> the people above faced the problem. Now they permanently disabled from >>> April 13th. >>> In a nutshell, Move to OAuth. >>> >>> -- >>> -- >>> Post: opend...@googlegroups.com >>> Unsubscribe: opendatakit...@googlegroups.com >>> Options: http://groups.google.com/group/opendatakit?hl=en >>> >>> --- >>> You received this message because you are subscribed to a topic in the >>> Google Groups "ODK Community" group. >>> To unsubscribe from this topic, visit >>> https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe. >>> To unsubscribe from this group and all its topics, send an email to >>> opendatakit...@googlegroups.com . >>> For more options, visit https://groups.google.com/d/optout. >>> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to a topic in the >> Google Groups "ODK Community" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe. >> To unsubscribe from this group and all its topics, send an email to >> opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

I don't know if this will help anyone however, this is what I was doing
when I started to get the error:

Problem:
I have a maven project setup running on Google App Engine Version: 1.9.25
and to update to the console - I would run the command in the terminal
(mac) "mvn gae:deploy".

My Fix:

  • I updated to Google App Engine Version: 1.9.34(in my pom.xml file)
  • I removed/commented out the "" sections from my
    web.xml file (With oAuth you no longer need this)
  • Added the GAE to my path "export
    PATH=$PATH://Applications/eclipse/plugins/appengine-java-sdk-1.9.34/bin"
  • Run the command: "mvn clean appengine:update"

If you are not authenticated, the terminal will ask you for a code
A browser window will automatically open asking you to allow the Google App
Engine and will provide you a code.
Copy and paste the code into the terminal.

Done!

This may not help everyone but I took over a project that was created 3
years ago and I'm sure everyone knows how annoying it can be when you take
over a new project.

Thanks!

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekassouf@timelesstech.com

Please consider the environment before printing this mail note.

ยทยทยท On Thu, Apr 14, 2016 at 12:23 PM, A.N.M AL-IMRAN wrote:

Hello Friends, Thanks a lot to Elie. However, I would request to the
experts in this group to volunteer to layout the sequences of installing
ODK using in a more collaboratively for those use ODK for years for their
work and do not have much technical knowledge, but with instructions they
will be able to manage. I believe many people got stuck at this point due
to this change. Since the previous installation process was pretty straight
forward. ODK experts did not updated the installation procedure using OAuth
2 yet. Thanks

On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote:

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Is there any instructions available for installation on OAuth? If anyone
already did that, please share it here in detail. Thanks
On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.b...@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when
the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I'm afraid I don't know. Are you sure you have created your App Engine
instance and have pointed the installer at the correct URL? 404 means it
isn't find the webpage where it expects.

ยทยทยท On Wed, Apr 13, 2016 at 10:38 AM, wrote:

Hi Imran & Sam,

I am stuck here as well with this error.
I am running the mvn gae:deploy command (mac terminal)

java.lang.RuntimeException: Bad authentication response: 404 Not Found
Unable to update app: Bad authentication response: 404 Not Found
Please see the logs
[/var/folders/v7/3ssx8xvs3n92yqcxyznmxxr80000gn/T/appcfg1204996708125139944.log]
for further information.

Who can I contact to resolve this issue?

Thanks!

Elie Kassouf

On Thursday, March 10, 2016 at 10:35:50 AM UTC-4, A.N.M AL-IMRAN wrote:

Dear Sam,

Thanks, I appreciate your support, The issue has been resolved. I
contacted Google app engine team, and they informed me that, they had a
service disruption, which was not allowing me to upload ODK to my
appengine. Now it is perfectly up and running. Learning from this problem
is, we all need to keep in mind that we need to think of issues on cloud
hosting end.

Thank you once again Sam

Imran

On Wednesday, March 9, 2016 at 3:47:24 PM UTC-5, Sam Sudar wrote:
I'm not positive, but that doesn't sound like a Java problem. 404 Is an
HTTP error saying it cannot find the URL. Are you on mac or windows?

Have you already created a new app engine project? Are you entering the
correct project ID when prompted in the Aggregate installer? When you go to
https://console.developers.google.com/, you should see a project you've
created to where you're going to upload the server. In one of the boxes on
my own page I see "Project Name: " and "ID: ".
Have you done this step? Are you entering the project id shown next to ID?

On Wed, Mar 9, 2016 at 9:43 AM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Thanks Sam,

Yes, actually the complete error message is as the following:
WARNING: Error posting to URL:

https://appengine.google.com/api/appversion/getresourcelimits?app_id=site-assessment&version=1&

401
Unauthorized
Must authenticate first.
This is try
#0
java.lang.RuntimeException: Bad authentication response: 404 Not
Found
Unable to update app: Bad authentication response: 404 Not Found

What do I need to consider during installing my jama. last two days I
have installed and uninstalled java at-least 20 times. Note: few times I
have installed it in a different drive other that C.

Your advice will be appreciated.

Thanks
Imran

A N M AL IMRAN (Imran)

Brossard, QC
Canada
Cell: +1 (438) 501 3576

On 9 March 2016 at 07:29, Sam Sudar suda...@gmail.com wrote:

Is there a more informative error farther down? Recently with
authentication problems I saw a "incorrect password" or something message.

With an app specific password on an account with two factor
authentication I had no problems. On an account without two factor auth I
had to go to security.google.com and toggle a switch to "allow sign in
from less secure apps" or something like that, then run the installer, then
turn the toggle off again.

On Wed, Mar 9, 2016, 12:51 AM A.N.M AL-IMRAN imra...@gmail.com wrote:

Hi All,

I am trying to install ODK Aggregate on Google app engine and getting
some error message:

"WARNING: Error posting to URL:
https://appengine.google.com/api/appversion/rollback?backend=background&app_id=site-assessment&401
Unauthorized
Must authenticate first.

"
I am using app specific password still cannot resolve the issue. Looking
forward for your help urgently, need to deploy my soon.

Thanks

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.

To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.

To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

What is truly unbelievable about this is that there is no notice of the
impact of that turn-down on the appcfg tool.

https://cloud.google.com/appengine/docs/java/tools/uploadinganapp

In any case, there will be a replacement for the upload script in the ODK
Aggregate 1.4.8 release, which will be out shortly.

ยทยทยท On Thu, Apr 14, 2016 at 8:36 AM, Elie Kassouf wrote:

I don't know if this will help anyone however, this is what I was doing
when I started to get the error:

Problem:
I have a maven project setup running on Google App Engine Version: 1.9.25
and to update to the console - I would run the command in the terminal
(mac) "mvn gae:deploy".

My Fix:

  • I updated to Google App Engine Version: 1.9.34(in my pom.xml file)
  • I removed/commented out the "" sections from my
    web.xml file (With oAuth you no longer need this)
  • Added the GAE to my path "export
    PATH=$PATH://Applications/eclipse/plugins/appengine-java-sdk-1.9.34/bin"
  • Run the command: "mvn clean appengine:update"

If you are not authenticated, the terminal will ask you for a code
A browser window will automatically open asking you to allow the Google
App Engine and will provide you a code.
Copy and paste the code into the terminal.

Done!

This may not help everyone but I took over a project that was created 3
years ago and I'm sure everyone knows how annoying it can be when you take
over a new project.

Thanks!

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekassouf@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 12:23 PM, A.N.M AL-IMRAN imran3may@gmail.com wrote:

Hello Friends, Thanks a lot to Elie. However, I would request to the
experts in this group to volunteer to layout the sequences of installing
ODK using in a more collaboratively for those use ODK for years for their
work and do not have much technical knowledge, but with instructions they
will be able to manage. I believe many people got stuck at this point due
to this change. Since the previous installation process was pretty straight
forward. ODK experts did not updated the installation procedure using OAuth
2 yet. Thanks

On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote:

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Is there any instructions available for installation on OAuth? If
anyone already did that, please share it here in detail. Thanks
On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.b...@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is
when the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks a lot Mitch, that would be the best solution ever. Imran

A N M AL IMRAN (Imran)
Brossard, QC
Canada
Cell: +1 (438) 501 3576

ยทยทยท On 14 April 2016 at 12:06, Mitch Sundt wrote:

What is truly unbelievable about this is that there is no notice of the
impact of that turn-down on the appcfg tool.

https://cloud.google.com/appengine/docs/java/tools/uploadinganapp

In any case, there will be a replacement for the upload script in the ODK
Aggregate 1.4.8 release, which will be out shortly.

On Thu, Apr 14, 2016 at 8:36 AM, Elie Kassouf ekassouf@timelesstech.com wrote:

I don't know if this will help anyone however, this is what I was doing
when I started to get the error:

Problem:
I have a maven project setup running on Google App Engine Version: 1.9.25
and to update to the console - I would run the command in the terminal
(mac) "mvn gae:deploy".

My Fix:

  • I updated to Google App Engine Version: 1.9.34(in my pom.xml file)
  • I removed/commented out the "" sections from my
    web.xml file (With oAuth you no longer need this)
  • Added the GAE to my path "export
    PATH=$PATH://Applications/eclipse/plugins/appengine-java-sdk-1.9.34/bin"
  • Run the command: "mvn clean appengine:update"

If you are not authenticated, the terminal will ask you for a code
A browser window will automatically open asking you to allow the Google
App Engine and will provide you a code.
Copy and paste the code into the terminal.

Done!

This may not help everyone but I took over a project that was created 3
years ago and I'm sure everyone knows how annoying it can be when you take
over a new project.

Thanks!

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekassouf@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 12:23 PM, A.N.M AL-IMRAN imran3may@gmail.com wrote:

Hello Friends, Thanks a lot to Elie. However, I would request to the
experts in this group to volunteer to layout the sequences of installing
ODK using in a more collaboratively for those use ODK for years for their
work and do not have much technical knowledge, but with instructions they
will be able to manage. I believe many people got stuck at this point due
to this change. Since the previous installation process was pretty straight
forward. ODK experts did not updated the installation procedure using OAuth
2 yet. Thanks

On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote:

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Is there any instructions available for installation on OAuth? If
anyone already did that, please share it here in detail. Thanks
On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.b...@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off
client login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is
when the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in
the Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I don't know if this will help anyone however, this is what I was doing when I started to get the error:

Problem:
I have a maven project setup running on Google App Engine Version: 1.9.25 and to update to the console - I would run the command in the terminal (mac) "mvn gae:deploy".

My Fix:

  • I updated to Google App Engine Version: 1.9.34(in my pom.xml file)

  • I removed/commented out the "" sections from my web.xml file (With oAuth you no longer need this)

  • Added the GAE to my path "export PATH=$PATH://Applications/eclipse/plugins/appengine-java-sdk-1.9.34/bin"

  • Run the command: "mvn clean appengine:update"

If you are not authenticated, the terminal will ask you for a code
A browser window will automatically open asking you to allow the Google App Engine and will provide you a code.
Copy and paste the code into the terminal.

Done!

This may not help everyone but I took over a project that was created 3 years ago and I'm sure everyone knows how annoying it can be when you take over a new project.

Thanks!

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

Hello Friends, Thanks a lot to Elie. However, I would request to the experts in this group to volunteer to layout the sequences of installing ODK using in a more collaboratively for those use ODK for years for their work and do not have much technical knowledge, but with instructions they will be able to manage. I believe many people got stuck at this point due to this change. Since the previous installation process was pretty straight forward. ODK experts did not updated the installation procedure using OAuth 2 yet. Thanks

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

Is there any instructions available for installation on OAuth? If anyone already did that, please share it here in detail. Thanks

Hello guys,

Root cause of this problem is that Google App Engine turned off client login from April 13th. Read the last paragraph in this link https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when the people above faced the problem. Now they permanently disabled from April 13th.
In a nutshell, Move to OAuth.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the Google Groups "ODK Community" group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hey Elie, Thanks for your informative post. I had done that to my ODK Aggregate, but tha last point is proving to be a heck of trouble. I copied and pasted the code from the web browser to my ODK Aggregate installer but the buttons aren't working. What am I supposed to do after copying and pasting the code. Please advise.

ยทยทยท On Thursday, April 14, 2016 at 6:36:53 PM UTC+3, Elie Kassouf wrote: > On Thu, Apr 14, 2016 at 12:23 PM, A.N.M AL-IMRAN wrote: > On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote: > On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN wrote: > On Apr 14, 2016 06:19, "Vidyasagar Bodapati" wrote:

It is possible that there could be some thing wrong with copy paste
too(something like it is picking up extra characters). You can try type in
the code for a quick test.

ยทยทยท On Tue, Jun 14, 2016 at 7:10 PM, wrote:

On Thursday, April 14, 2016 at 6:36:53 PM UTC+3, Elie Kassouf wrote:

I don't know if this will help anyone however, this is what I was doing
when I started to get the error:

Problem:
I have a maven project setup running on Google App Engine Version:
1.9.25 and to update to the console - I would run the command in the
terminal (mac) "mvn gae:deploy".

My Fix:

  • I updated to Google App Engine Version: 1.9.34(in my pom.xml file)

  • I removed/commented out the "" sections from my
    web.xml file (With oAuth you no longer need this)

  • Added the GAE to my path "export
    PATH=$PATH://Applications/eclipse/plugins/appengine-java-sdk-1.9.34/bin"

  • Run the command: "mvn clean appengine:update"

If you are not authenticated, the terminal will ask you for a code
A browser window will automatically open asking you to allow the Google
App Engine and will provide you a code.
Copy and paste the code into the terminal.

Done!

This may not help everyone but I took over a project that was created 3
years ago and I'm sure everyone knows how annoying it can be when you take
over a new project.

Thanks!

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 12:23 PM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Hello Friends, Thanks a lot to Elie. However, I would request to the
experts in this group to volunteer to layout the sequences of installing
ODK using in a more collaboratively for those use ODK for years for their
work and do not have much technical knowledge, but with instructions they
will be able to manage. I believe many people got stuck at this point due
to this change. Since the previous installation process was pretty straight
forward. ODK experts did not updated the installation procedure using OAuth
2 yet. Thanks

On Thursday, April 14, 2016 at 8:08:34 AM UTC-4, Elie Kassouf wrote:

https://cloud.google.com/appengine/docs/java/tools/remoteapi#configuring_remote_api_on_a_standalone_client

Elie G Kassouf
Mobile Developer
Timeless Technologies

ekas...@timelesstech.com

Please consider the environment before printing this mail note.

On Thu, Apr 14, 2016 at 7:29 AM, A.N.M AL-IMRAN imra...@gmail.com wrote:

Is there any instructions available for installation on OAuth? If anyone
already did that, please share it here in detail. Thanks

On Apr 14, 2016 06:19, "Vidyasagar Bodapati" < sagar.b...@enterprisenube.com> wrote:

Hello guys,

Root cause of this problem is that Google App Engine turned off client
login from April 13th. Read the last paragraph in this link
https://cloud.google.com/appengine/docs/deprecations/clientlogin#migrating_from_clientlogin_to_oauth_20

On March 8th Google tested it by turning it off for 1 day which is when
the people above faced the problem. Now they permanently disabled from
April 13th.
In a nutshell, Move to OAuth.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.

To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.

To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--

--

Post: opend...@googlegroups.com

Unsubscribe: opendatakit...@googlegroups.com

Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.

To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.

To unsubscribe from this group and all its topics, send an email to
opendatakit...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Hey Elie, Thanks for your informative post. I had done that to my ODK
Aggregate, but tha last point is proving to be a heck of trouble. I copied
and pasted the code from the web browser to my ODK Aggregate installer but
the buttons aren't working. What am I supposed to do after copying and
pasting the code. Please advise.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/opendatakit/KpE_v9Aqs8c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.