Cannot install ODK Aggregate on macOS 10.15

I can't install ODK Aggregate v2.0.5 on my MacOS 10.15. Newbie--any tips appreciated.

Followed the steps in https://docs.opendatakit.org/aggregate-tomcat/ to install Tomcat 8.5.49 (verified can start and stop successfully), and already had postgresql 10 installed on machine. Then I tried to do step 7: Install ODK Aggregate. Downloaded ODK-Aggregate-v2.0.5-macOS.app.zip from the github page, unzipped, then did right-click Open to bypass the "developer not verified" warning. When I run the unzipped application, it does nothing.

Then in a terminal, I went to ~/Downloads/ODK-Aggregate-v2.0.5-macOS.app/Contents/MacOS and tried running installbuilder.sh. Not sure if this is helpful, but when I run the installbuilder.sh script it says:

./installbuilder.sh: line 20: ./osx-intel: Bad CPU type in executable

Not sure how to proceed from here. Thanks in advance.