Cascading select not showing the third selection

1. What is the problem? Be very detailed.
Am building a form with xlsx and am trying to configure the cascading select for these items District, Cluster and Village. when i select the district it shows me the clusters in that district in the select cluster name dropdown list, but when i proceed to Village name it doesnot show me the villages in the selected clusters. It asks me to select one answer and when i click to select it shows remove response. It cannot display the village names.

2. What app or server are you using and on what device and operating system? Include version numbers.
Am using ODK collect v1.21.1
3. What you have you tried to fix the problem?
Tried reducing on the number of villages but the problem is failing, tried removing the appearance it also failed to display.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
attache dis the xlsx file
IT_Testing_Form.xlsx (19.4 KB)

IT_Testing_Form.xlsx (19.8 KB)
Try this one

Thank you so much, it is working perfectly