Constraint (. >= 0) Falsely Giving Error in ODK Collect v1.23.1

1. What is the problem? Be very detailed.

We have several forms with . >= 0 as a constraint. This has always worked properly, until the most recent ODK Collect v1.23.1. Currently, after filling in a number that is greater than 0, the error message "Entry must be greater than or equal to 0!" still pops up! If you swipe right to the previous screen and then swipe left twice you can get beyond this. Any subsequent swipes do not cause the error. The error only comes on the first swipe attempt after filling in a greater than 0 value.

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Collect v1.23.1

3. What you have you tried to fix the problem?

We have tested this on multiple phones and every phone with v1.23.1 is having this behavior. Because we haven't made any changes to our form in the last couple of months, and the problem just recently has started, our only conclusion is that this is an ODK Collect bug.

4. What steps can we take to reproduce the problem?

You can use this XLSX file for testing. We have the constraint on the second question if you select no to the first question.

S4W_Africa_v1.0.xlsx (70.3 KB)

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

1 Like

Sorry, I spent some time searching the threads before making this post and couldn't find anything, but I just found this post

and it looks like this was reported already! I updated to v1.23.2 and the bug has been squashed. Great work ODK team. You guys are the best!


@Jeff_Davids Thanks for reporting the issue. To help us catch these issues before they reach production, please do join the beta.