Downloading of converted forms broken?

Well done to you all!

Could you check on the downloading of converted forms? Seems not to be working. I keep getting redirected to a blank page with 12345678 in the top left corner.


Hi @Leangelindiku17

Please provide a link to the page. I can not find it.
You can also open an issue on the website Github page. Pull requests with the fix are most welcome.

When I go to or, I am able to upload a XLSForm and get back an XForm. Is that the same page you are going to @Leangelindiku17?

Hello @Yaw

I am using the online converter and downloader from:

I did finally manage to download forms when using Chrome. It seems the error only occurs when using Microsoft Edge.


1 Like

Thank you @Leangelindiku17 for reporting this issue. I have filed it at If anyone else has tried it on Edge, it would be great to get your experience.

@Leangelindiku17 I looked into this issue and pushed a fix a few minutes ago. Can you try Microsoft Edge and see if it works now?

It now works fine on Edge.


1 Like