Error: Address already in use - bind(2) Odk Build

Hi,

I install tokyocabinet, tokyotyrant in my local system and manage to run
odk build , when i start the server it works fine, and i see the odk build
form in localhost in 127.0.0.1:9393/ but when i started on the next day,
it says the following error when i run "bundle exec shotgun config.ru"

root@ubuntu:/home/naveen/Desktop/odkbuild-master# bundle exec shotgun
config.ru
/usr/lib/ruby/vendor_ruby/bundler/runtime.rb:136: warning: Insecure world
writable dir /usr/local/sbin in PATH, mode 040777
/usr/lib/ruby/vendor_ruby/bundler/runtime.rb:136: warning: Insecure world
writable dir /usr/local/sbin in PATH, mode 040777
== Shotgun/WEBrick on http://127.0.0.1:9393/
[2013-07-08 10:08:54] INFO WEBrick 1.3.1
[2013-07-08 10:08:54] INFO ruby 1.8.7 (2011-06-30) [x86_64-linux]
[2013-07-08 10:08:54] WARN TCPServer Error: Address already in use -
bind(2)
/usr/lib/ruby/1.8/webrick/utils.rb:73:in initialize': Address already in use - bind(2) (Errno::EADDRINUSE) from /usr/lib/ruby/1.8/webrick/utils.rb:73:in new'
from /usr/lib/ruby/1.8/webrick/utils.rb:73:in create_listeners' from /usr/lib/ruby/1.8/webrick/utils.rb:70:in each'
from /usr/lib/ruby/1.8/webrick/utils.rb:70:in create_listeners' from /usr/lib/ruby/1.8/webrick/server.rb:75:in listen'
from /usr/lib/ruby/1.8/webrick/server.rb:63:in initialize' from /usr/lib/ruby/1.8/webrick/httpserver.rb:24:in initialize'
from
/var/lib/gems/1.8/gems/rack-1.3.4/lib/rack/handler/webrick.rb:10:in new' from /var/lib/gems/1.8/gems/rack-1.3.4/lib/rack/handler/webrick.rb:10:in run'
from /var/lib/gems/1.8/gems/shotgun-0.9/bin/shotgun:156
from /var/lib/gems/1.8/bin/shotgun:19:in `load'
from /var/lib/gems/1.8/bin/shotgun:19

Could anyone help to solve this error.
Thanks
Naveen

I tried This code in terminal "lsof -wni tcp:3000" and "kill -9 PID" After
this i start the server using "rake db:dev:start" it gets started then i
use this code "bundle exec shotgun config.ru" Now the page look like the
following image

https://lh6.googleusercontent.com/-_9tctQabIwo/UdqKHemmQ9I/AAAAAAAAAIo/VAhHF1uUCkM/s1600/Screenshot+from+2013-07-08+10%3A38%3A32.png
Could anyone help to solve this errors.
Many Thanks
Naveen

Naveen,

Try rebooting.

Yaw

ยทยทยท -- Need ODK help? Go to http://nafundi.com for custom features, form design, implementation support, and user training for ODK.

On Mon, Jul 8, 2013 at 2:47 AM, NAVEENKUMAR G navi.it14@gmail.com wrote:

I tried This code in terminal "lsof -wni tcp:3000" and "kill -9 PID" After
this i start the server using "rake db:dev:start" it gets started then i
use this code "bundle exec shotgun config.ru" Now the page look like the
following image

https://lh6.googleusercontent.com/-_9tctQabIwo/UdqKHemmQ9I/AAAAAAAAAIo/VAhHF1uUCkM/s1600/Screenshot+from+2013-07-08+10%3A38%3A32.png
Could anyone help to solve this errors.
Many Thanks

Naveen

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.