Error Message when upload media file in ODK using MYSQL

Hi friends.

I got this below error message when i upload media files(csv file)with form.

Problem persisting data or accessing data
org.opendatakit.common.persistence.exception.ODKEntityPersistException:
org.springframework.dao.TransientDataAccessResourceException:
PreparedStatementCallback; SQL [INSERT INTO
odk_prod._form_info_manifest_blb ( _URI, _CREATOR_URI_USER,
_CREATION_DATE, _LAST_UPDATE_URI_USER, _LAST_UPDATE_DATE,
_TOP_LEVEL_AURI, VALUE ) VALUES ( ?, ?, ?, ?, ?, ?, ? ) ]; Packet for
query is too large (4729356 > 4194304). You can change this value on the
server by setting the max_allowed_packet' variable.; nested exception is
com.mysql.jdbc.PacketTooBigException: Packet for query is too large
(4729356 > 4194304). You can change this value on the server by setting the
max_allowed_packet' variable.

kindly any one resolve this issue.

Hi there,

I don't know what version of ODK Aggregate you are using, but I think
since 1.4.7 we've asked folks who install on MySQL/MariaDB to
configure the DB's max_allowed_packet to 1073741824. If you do that
and reboot, it should work.


has more.

Yaw

ยทยทยท On Fri, May 19, 2017 at 8:54 AM, wrote: > Hi friends. > > I got this below error message when i upload media files(csv file)with form. > > Problem persisting data or accessing data > org.opendatakit.common.persistence.exception.ODKEntityPersistException: > org.springframework.dao.TransientDataAccessResourceException: > PreparedStatementCallback; SQL [INSERT INTO > `odk_prod`.`_form_info_manifest_blb` ( `_URI`, `_CREATOR_URI_USER`, > `_CREATION_DATE`, `_LAST_UPDATE_URI_USER`, `_LAST_UPDATE_DATE`, > `_TOP_LEVEL_AURI`, `VALUE` ) VALUES ( ?, ?, ?, ?, ?, ?, ? ) ]; Packet for > query is too large (4729356 > 4194304). You can change this value on the > server by setting the max_allowed_packet' variable.; nested exception is > com.mysql.jdbc.PacketTooBigException: Packet for query is too large (4729356 >> 4194304). You can change this value on the server by setting the > max_allowed_packet' variable. > > kindly any one resolve this issue. > > -- > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en > > --- > You received this message because you are subscribed to the Google Groups > "ODK Community" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to opendatakit+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout.