Error setting passwords on Aggregate RC1

Hi,

Not sure if this is just me or not (couldn;t see anyone else had
reported this), but I'm unable to set any ODK user passwords through
the ODK Aggregate admin page (logged in as the administrative user). I
can create a user fine, but every time I try to change the password I
get the error message:

"JSON change-password request to https://odk.digital-campus.org/ODKAggregate/ssl/user-manage-passwords
failed"

I'm running Aggregate RC1 and I upgraded couple of days ago from beta

  • nor sure If I missed something in the upgrade process? Are there any
    requirements on the length.format etc of the passwords?

Alternatively is there a way I can set the passwords directly in the
database?

Any help much appreciated,
thanks,
Alex

filed at http://code.google.com/p/opendatakit/issues/detail?id=347.
please track it there.

··· On Sat, Oct 1, 2011 at 10:44, Alex Little wrote: > Hi, > > Not sure if this is just me or not (couldn;t see anyone else had > reported this), but I'm unable to set any ODK user passwords through > the ODK Aggregate admin page (logged in as the administrative user). I > can create a user fine, but every time I try to change the password I > get the error message: > > "JSON change-password request to https://odk.digital-campus.org/ODKAggregate/ssl/user-manage-passwords > failed" > > I'm running Aggregate RC1 and I upgraded couple of days ago from beta > - nor sure If I missed something in the upgrade process? Are there any > requirements on the length.format etc of the passwords? > > Alternatively is there a way I can set the passwords directly in the > database? > > Any help much appreciated, > thanks, > Alex > > -- > Post: opendatakit@googlegroups.com > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > Options: http://groups.google.com/group/opendatakit?hl=en >

It was working for me with RC1, but now I get the same error of you
with RC2 upgrade...

··· On 1 Ott, 19:44, Alex Little wrote: > Hi, > > Not sure if this is just me or not (couldn;t see anyone else had > reported this), but I'm unable to set any ODK user passwords through > the ODK Aggregate admin page (logged in as the administrative user). I > can create a user fine, but every time I try to change the password I > get the error message: > > "JSON change-password request tohttps://odk.digital-campus.org/ODKAggregate/ssl/user-manage-passwords > failed" > > I'm running Aggregate RC1 and I upgraded couple of days ago from beta > - nor sure If I missed something in the upgrade process? Are there any > requirements on the length.format etc of the passwords? > > Alternatively is there a way I can set the passwords directly in the > database? > > Any help much appreciated, > thanks, > Alex

SOLVED: The pw must be set using the domain, while it fails if set
through localhost.

··· On 6 Ott, 10:35, giohappy wrote: > It was working for me with RC1, but now I get the same error of you > with RC2 upgrade... > > On 1 Ott, 19:44, Alex Little wrote: > > > > > > > > > Hi, > > > Not sure if this is just me or not (couldn;t see anyone else had > > reported this), but I'm unable to set any ODK user passwords through > > the ODK Aggregate admin page (logged in as the administrative user). I > > can create a user fine, but every time I try to change the password I > > get the error message: > > > "JSON change-password request tohttps://odk.digital-campus.org/ODKAggregate/ssl/user-manage-passwords > > failed" > > > I'm running Aggregate RC1 and I upgraded couple of days ago from beta > > - nor sure If I missed something in the upgrade process? Are there any > > requirements on the length.format etc of the passwords? > > > Alternatively is there a way I can set the passwords directly in the > > database? > > > Any help much appreciated, > > thanks, > > Alex