External selects stopped working

1. What is the problem? Be very detailed.
I have cascading selects with both choices and external choices. I have been using this survey for the past 10 months and it has been working great. I have not uploaded a new version but suddenly the external selects have stopped working. Specifically, you can select a union, a village and a bari (all regular choices), but as soon as the cascade gets to the household, no answers choices appear on the survey.

This problem is really odd since these selects have been working for months. My survey team noticed the issue with one particular bari, but after checking it seems this problem occurs with all baris - no households are showing up for any bari.

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using ODK Collect version 1.22.0 on a Samsung Galaxy Tab A with Android version 8.1.0. They survey was built with XLSForm.

3. What you have you tried to fix the problem?
I have double checked the choices and created a small survey with only these questions to ensure it's not something else with the survey. Even in the small survey this problem persists.

4. What steps can we take to reproduce the problem?
The form is available on request as there is some personal information contained in it.

I think this issue was resolved with a later version of odk Collect 1.22.1 by @LN. You could try updating the app to 1.22.4

1 Like

Thanks for the reply, Paul! I just updated ODK to version 1.22.4 and unfortuantely I still have the problem.

Did you push out a new version of your form by any chance? My initial suspicion is that a change to XLSForm is causing the issue. I will look into it deeper soon but knowing that piece of information would be helpful.

I didn't push a new version - but the form I uploaded (select_test.xlsx) is a new form with only these geographic identifier questions. In this sample form, the questions, choices, and external choices were taken directly from my original survey form and the list of households in each bari do not show up for any bari.

An odd glitch I've just discovered is that If I revert to a much older version of the form, then the problem almost goes away - with the exception of one case (at least one that I'm aware of). This specific case is found by selecting:
Union = Gorai
Village = Path Hara

Are you absolutely sure you haven't updated the form in some way? I see that the latest XLSForm converter versions generate blank itemset.csv files which would certainly explain the behavior you're seeing. I tried your sample form after converting it with pyxform v0.13.0 and I can confirm that it works.

Hopefully we can get a fix for that out soon. In the mean time, you can download a prior version of XLSForm offline or simply create your own itemsets.csv file by exporting the external_choices sheet to a CSV with filename itemsets.csv.

I think the problem is with the parentheses. Ideally, the name column would contain a code for the value that is only numbers and letters. In practice, it's ok to have spaces when using single selects but it's really important not to have them when using multiple selects. Could you double check whether removing the parentheses works for you?

I was fairly sure - but now that I'm looking at the itemsets.csv files I see they are all empty! I just got a new computer and downloaded the latest version of XLSForm offline - so that must be the issue!

I'll try downloading the older version and removing the parentheses for that one bari!

Thank you so much for your help!

1 Like

Removing the parentheses and working with the older version of XLSForm solved the problem! Thank you so much for your help!

1 Like

Issue has been fixed in the newest releases of ODK XLSForm Online v1.6 and ODK XLSForm Offline v1.11.