First attempt at contributing line edit

Greetings, ODK community. I am a very new participant in the ODK community. I am also new to GitHub and Atom, so this has been a thrilling day of Hello World tutorials for me! After reading through the ODK docs contribution guides and completing some of the basic tutorials, I have tried my hand at my first simple line edit to the ODK documentation, since my beginner status only qualifies me to help out with correction of minor grammatical issues at this time. I believe I made it most of the way correctly, but at the moment I attempted to use GitHub Desktop to Publish Branch, I received this message:

Authentication failed. You may not have permission to access the repository or the repository may have been archived. Open options and verify that you're signed in with an account that has permission to access this repository.

I would be most grateful for any guidance in navigating this process from those more experienced than myself. Please let me know if I have missed any steps required to begin actively contributing to documentation. Thank you all!

Hello! Thank you for attempting to contribute. I saw your intro post and I was amazed at how quickly you wanted to jump in and give back to the project.

I don't use GitHub desktop, but some Googling around suggests this might be related to Git LFS, which we use to handle all our images, videos, and other binary files.

If you haven't installed GLFS, make sure you do so.

Also, I understand some version (?) of GitHub desktop was being deprecated in the last year. Do you have the latest from GitHub, or is this an older version already on your machine?

I would also try using the command line if possible. When I first started using GitHub I used the desktop app also, but after a while I found using the command line to just be easier. Also --- all of our instructions are command-line based, so you're less likely to get tripped up. (And it'll be easier for me and others to help.)

(If you're on a Linux, I assume you know where your terminal is. On Mac it's an app called 'Terminal'. On Windows, I suggesting using the gitbash terminal that come with git.)

That being said, there's no reason I know of why you shouldn't be able to use the desktop app. I'll look into it a bit more. Maybe someone else on the forum can shed some light as well.

1 Like

Thank you for your help and kind words! It is exciting to encounter a place where one can fall down rabbit holes that teach useful and increasingly challenging things. The version of GitHub desktop I'm using is indeed the latest, and I'm using it on Windows. I'll make sure to install Git LFS and will start learning the command line. Tomorrow (or today, as it has now become in my time zone) I'll be in a strange offline land for most of the day where even ODK Collect cannot tread, but when I come home in the evening I'll see how much I can figure out on my own. If I'm still stuck, I'll let you know where the problem is, and if I triumph, I'll let you know what worked! It will be fun to brave a command line again. I have not had to do anything of that nature since a very long time ago when I spent three months learning Unix.

1 Like

I believe I have solved the problem I was having with GitHub Desktop on Windows. I have also started learning to use the command line with GitBash, but I'm still running into errors when trying to submit my line edit using the command line. I'll keep going through online resources I am finding to address that problem, but in the meantime I believe (I hope!) I have successfully contributed my line edit through GitHub Desktop. (Or I might have accidentally contributed it to myself, I'm not sure!) What does the ODK community think of the Pro Git text as an introduction to the concept of version control and how git works in general? I've started reading that, so I'm hoping that will help me as a non-computer scientist get a better sense for what is actually happening when I use the command line to interact with GitHub.

Thank you again for your help!