Form deletion failing


I am trying to upgrade a form on aggregate. The new version has a lot of changes, so I decided to delete the existing form and upload the new form as a fresh copy. The existing form had around 600 submissions, including around 5 images per submission too. When I ran the DELETE command in aggregate, it asked me to wait for some time until data gets cleared, after which I can upload the fresh form. But it has been around 2 hours and the data is still not cleared, since aggregate is not letting me upload the fresh form, saying that there is clash with existing form for namespace and I should wait till complete deletion. If I check tomcat logs, there is no activity of deletion happening, and the server is sitting peacefully. When I check the database directly, aggregate table for that form has 451 entries, and they are not reducing in number since last 1.5 hours (since when I am watching).

Please suggest what should I do now. I cannot force the deletion of form because it is not on aggregate anymore, and I cannot force-delete from backend database because it would leave inconsistency. What should be the option to move forward?