Form in Get Forms no longer available

1. What is the problem? Be very detailed.

User in China has the app installed. A new version of the form was provided by me through the same server settings as he had configured in his mobile odk collect. So he deleted the previous version blank form and now he is not able to get the updated form to him. I checked ODK aggregate and the form is as downloadable for his account.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Collect 1.8
3. What you have you tried to fix the problem?
Reconfigured the settings on app, downloaded the app again, and tried to capture data again.
4. What steps can we take to reproduce the problem?
I was not able to reproduce the problem from different mobiles (different locations)
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
image

Hi @Lara_VR
is that really v1.8? If so could you try to update we have v1.24 now.

Hi, Thank you for your quick response!
The version is indeed 1.8. I do not have the capacity to update that now as it was facilitated for us by an external service provider.
I am sorry for being so limited on know-how, but I have my hands full with customer requests.
Are there any other alternatives? Kind Regards