Form listing failed

OK I installed ODK Aggregate V1.0 RC2. I uploaded my two forms. I
granted the anonymousUser data collector rights because I am using
1.1.5 Collect.

When I go to manage data and forms and try to add new forms I get the
following

Form listing failed.
DocumnetBuilderFactory error: Unexpected end of document.

Thanks again for any help.

Andy

It sounds like a mismatched XML or HTML tag in the form.

Have you run ODK Verify?

If you manually place those exact same forms on the phone (in the
/sdcard/odk/forms directory), can you open them on ODK Collect 1.1.5 ?

Mitch

··· On Sun, Oct 16, 2011 at 4:06 PM, Andrew Faust wrote:

OK I installed ODK Aggregate V1.0 RC2. I uploaded my two forms. I
granted the anonymousUser data collector rights because I am using
1.1.5 Collect.

When I go to manage data and forms and try to add new forms I get the
following

Form listing failed.
DocumnetBuilderFactory error: Unexpected end of document.

Thanks again for any help.

Andy

--
Mitch Sundt
Software Engineer


University of Washington
mitchellsundt@gmail.com

If I manually place those forms on the phone ODK Collect does see them
but fails when I try to send them.

When I run Validate on them all kinds of errors:
Parsing form...
Title: "WHAM092311"
Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture1" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture1" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture2" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture2" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture3" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture3" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [data] and will be
ignored: [id] Location:

Problem found at nodeset: /html/head/model/instance/data
With element <data id="build_WHAM092311_1318877908">
··· >> Xform is valid! See above for any warnings.

On Oct 17, 11:26 am, Mitch Sundt msu...@cs.washington.edu wrote:

It sounds like a mismatched XML or HTML tag in the form.

Have you run ODK Verify?

If you manually place those exact same forms on the phone (in the
/sdcard/odk/forms directory), can you open them on ODK Collect 1.1.5 ?

Mitch

On Sun, Oct 16, 2011 at 4:06 PM, Andrew Faust afa...@ncwrpc.org wrote:

OK I installed ODK Aggregate V1.0 RC2. I uploaded my two forms. I
granted the anonymousUser data collector rights because I am using
1.1.5 Collect.

When I go to manage data and forms and try to add new forms I get the
following

Form listing failed.
DocumnetBuilderFactory error: Unexpected end of document.

Thanks again for any help.

Andy

--
Mitch Sundt
Software Engineerhttp://www.OpenDataKit.org
University of Washington
mitchellsu...@gmail.com

If I put the forms on the manually they show up and work but fail when
I try to send them.

When I run Verify there are all kinds of errors:

Parsing form...
Title: "WHAM092311"
Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture1" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture1" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture2" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture2" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [mediatype] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture3" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [upload] and will
be ignored: [ref] Location:

Problem found at nodeset: /html/body/upload
With element <upload ref="/data/Picture3" mediatype="image/*">

Warning: 1 Unrecognized attributes found in Element [data] and will be
ignored: [id] Location:

Problem found at nodeset: /html/head/model/instance/data
With element <data id="build_WHAM092311_1318877908">
··· >> Xform is valid! See above for any warnings.

On Oct 17, 11:26 am, Mitch Sundt msu...@cs.washington.edu wrote:

It sounds like a mismatched XML or HTML tag in the form.

Have you run ODK Verify?

If you manually place those exact same forms on the phone (in the
/sdcard/odk/forms directory), can you open them on ODK Collect 1.1.5 ?

Mitch

On Sun, Oct 16, 2011 at 4:06 PM, Andrew Faust afa...@ncwrpc.org wrote:

OK I installed ODK Aggregate V1.0 RC2. I uploaded my two forms. I
granted the anonymousUser data collector rights because I am using
1.1.5 Collect.

When I go to manage data and forms and try to add new forms I get the
following

Form listing failed.
DocumnetBuilderFactory error: Unexpected end of document.

Thanks again for any help.

Andy

--
Mitch Sundt
Software Engineerhttp://www.OpenDataKit.org
University of Washington
mitchellsu...@gmail.com

hi andrew,

the warnings are fine. we are looking for real errors (the text in
validate will turn red). from what you've described the form doesn't
seem to be the issue. could you please add yanokwa@gmail.com to your
aggregate server (if it's on appengine) and send me an email when it's
done?

i've filed your issue at
http://code.google.com/p/opendatakit/issues/detail?id=377 and we'll
update things there. thanks so much for your patience,

yaw

··· On Mon, Oct 17, 2011 at 12:13, Andrew Faust wrote: > If I put the forms on the manually they show up and work but fail when > I try to send them. > > When I run Verify there are all kinds of errors: > > Parsing form... > Title: "WHAM092311" > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [mediatype] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [ref] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [mediatype] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [ref] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [mediatype] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [upload] and will > be ignored: [ref] Location: > > Problem found at nodeset: /html/body/upload > With element > > Warning: 1 Unrecognized attributes found in Element [data] and will be > ignored: [id] Location: > > Problem found at nodeset: /html/head/model/instance/data > With element > > > > >>> Xform is valid! See above for any warnings. > > > On Oct 17, 11:26 am, Mitch Sundt wrote: >> It sounds like a mismatched XML or HTML tag in the form. >> >> Have you run ODK Verify? >> >> If you manually place those exact same forms on the phone (in the >> /sdcard/odk/forms directory), can you open them on ODK Collect 1.1.5 ? >> >> Mitch >> >> On Sun, Oct 16, 2011 at 4:06 PM, Andrew Faust wrote: >> > OK I installed ODK Aggregate V1.0 RC2. I uploaded my two forms. I >> > granted the anonymousUser data collector rights because I am using >> > 1.1.5 Collect. >> >> > When I go to manage data and forms and try to add new forms I get the >> > following >> >> > Form listing failed. >> > DocumnetBuilderFactory error: Unexpected end of document. >> >> > Thanks again for any help. >> >> > Andy >> >> -- >> Mitch Sundt >> Software Engineerhttp://www.OpenDataKit.org >> University of Washington >> mitchellsu...@gmail.com >