GeoODK Collect error "Unfortunately, GeoODK collect has stopped"

What is the problem? Please be detailed.

GeoODK Collect gives me the error "Unfortunately, GeoODK collect has stopped", whenever I try to save the form during the filling in of the form. Also when I try to fill in the form and am at the last question, it does not go to the finalize page but it gives the error.

What ODK tool and version are you using? And on what device and operating system version?
I am using the GeoODK Collect version 2.0.3 and I am on a Samsung Galaxy Tab A, android tablet.

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?
I have already tried reinstalling the app, restarting the tablet.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
I cannot upload my form just yet, as I am restricted as a new user.

Anybody have an idea what I could do?

Thank you

Hi @Kimberley_Fung-Loy you might try installing just regular ODK-Collect. This depends on what features of GeoODK you were using. Most of them are merged now into regular Collect though.