Getting Issue while making Build Of ODK Central

  1. What is the problem? Be very detailed.

We get into below problem while moving docker default path from /var/lib/docker to some other location and we have not taken backup of old /var/lib/docker directory because we are using custom postgres database server.

Problem Statement :

We were trying to rebuild central verion 1.2 but it got failed with error like authentication error while installing some new package. After that we have taken latest pull from central official git repository and follow the the document Upgrade Central to version 1.3 (https://docs.getodk.org/central-upgrade/). In this case we are able to make build but geeting two problem:

  1. nginx getting unhealhty but we are able to login into central and see all the previous data.
  2. We are not able to preview any old form in enketo but able to create a new form as well as preview.

So below are my concern:

  • Should it requied to take backup of old docker directory even we are using external database server??
  • Why we are getting authentication error while building version 1.2.
  • Why nginx getting unhealhty in version 1.3
  • Why we are not able to preview older form on enketo??
  1. What app or server are you using and on what device and operating system? Include version numbers.

    APP Name - ODK Central
    Server - Oracle Linux 7
    ODK Central Version -

     versions:
     	24ee74e5f974a518aa1cc8b06e7addb3be6b4690 (v1.3.3-2-g24ee74e)
     	5cc6fd79d112ce36d6298c61bb8817689c4c323b client (v1.3.2)
     	1d1a3a59969e61383da74119e405e67778b7a170 server (v1.3.3)
    
  2. What you have you tried to fix the problem?

    Clean restart of docker.
    Clean build of ODK Central.
    Tried with customssl.

  3. What steps can we take to reproduce the problem?

  4. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
    image

Hello Everyone,
Can someone help into this issue.

Regards,
Abhishek