Install Central beside Aggregate - port


  1. How to define a port for the Central server ?

I cannot access Central, probably because Aggregate under Tomcat server is installed on port 8080. Example: / ...

Here is how I configured the .env

SSL_TYPE = letsencrypt
DOMAIN = 31234

  1. I'm on Ubuntu Server 18.04


I'm guessing you're following the instructions here and using docker-compose to deploy Central? If so, looking at the docker-compose.yml for Central you'll see that it binds to ports here:

      - "80:80"
      - "443:443"

This means that the container that's running Central's interface is binding is exposing it's port 80 and port 443 on the local machine's corresponding 80 and 443. If you want Central to run on port 31234 I think you'll need to change the "80:80" to "31234:80" in your local docker-compose.yml.

Thank you seadowg

Unfortunately it doesn't work. Could this be because the nginx server is pointing to (see the picture from what docker-compose ps gives me).

Note that all my ports are open

Could you post more details around how you're trying to access Central and what problems you're seeing?

Yes, I'm trying to log into Central through google, but I still get the note: this site is unreachable. As much when I go with my IP address only, for example: as when I affix the port 443 or 80 or 31234

Not sure what you mean by this. Could you elaborate?

Have you tried checking if something is already running on port 80 before running docker-compose up?

Did you try changing the domain and ports as I suggested earlier? It looks like you're still running on port 80.

1 Like

@ps_lachute I'm pretty sure that there isn't a port conflict with Aggregate. As you described, it's running on port 8080 (and perhaps 8443) for HTTPS.

What might be the problems is that your env file has a domain of DOMAIN = 31234. The domain should only be the fully qualified domain name (e.g., Note that this is the domain that Central will use to fetch SSL certs.

If you are having trouble, I'd recommend you try setting up Central on its own machine first and make sure that works before trying to run it on a machine with Aggregate.