Installation - docker on Ubuntu 16 - Failed to start central via docker-compose

Hi All,

I have tried to installk ODK central on my own Ubuntu 16 server . Fist I installed docker and docker compose (have versions Docker version 18.09.3 and docker-compose version 1.17.0 and followd the instructions in https://docs.opendatakit.org/central-install-digital-ocean/ .
Now everything worked fine until I try launching the docker image with ODK - central via systemctl start docker-compose@central . When I check with
systemctl status docker-compose@central I get this output:

docker-compose@central.service: Unit entered failed state.
docker-compose@central.service: Failed with result 'exit-code'.
docker-compose@central.service: Service hold-off time over, scheduling restart.
Stopped central via docker-compose.
docker-compose@central.service: Start request repeated too quickly.
Failed to start central via docker-compose.
docker-compose@central.service: Unit entered failed state.
docker-compose@central.service: Failed with result 'start-limit-hit'.

How can I fix this and get ODK central to start ?

Cheers
Karsten

hi karsten:

what happens if you do the following?

systemctl stop docker-compose@central
cd central
docker-compose up

you don't have to cd central if you're already in that project folder.

3 Likes

Thanks Clint .
Great that worked !!!
The container is starting with postgres nginx etc,. the only thing I need to do was to stop the apache2 service that is running on the server to make that go through

oh, i see! we will add notes to check for that case and fix it in the future, then.

i think now that you've solved the issue with apache you can probably stop the docker-compose command and go back to using systemctl start docker-compose@central if you haven't already.

Hey, I have a question in addition to karsten's.

I've also setup central on ubuntu, but 18.04. I followed your steps and they indeed do get it running. However, you closed with a comment mentioning that we can stop the docker-compose command and go back to using 'systemctl start docker-compose@central' which I've tried and still brings up the initial errors.

Please help, as I'd like to setup central up to start automatically, regardless of any system failure.

In addition to my previous post, here's my output for 'systemctl status docker-compose@central' (de-identified):

systemctl status docker-compose@central

‚óŹ docker-compose@central.service - central via docker-compose
Loaded: loaded (/etc/systemd/system/docker-compose@.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since MMM dd hh:mm:ss CAT; 22min ago
Process: 6995 ExecStart=/usr/local/bin/docker-compose up (code=exited, status=200/CHDIR)
Main PID: 6995 (code=exited, status=200/CHDIR)

MMM dd hh:mm:ss ***** systemd[1]: docker-compose@central.service: Service hold-off time over, scheduling restart.
MMM dd hh:mm:ss ***** systemd[1]: docker-compose@central.service: Scheduled restart job, restart counter is at 5.
MMM dd hh:mm:ss ***** systemd[1]: Stopped central via docker-compose.
MMM dd hh:mm:ss ***** systemd[1]: docker-compose@central.service: Start request repeated too quickly.
MMM dd hh:mm:ss ***** systemd[1]: docker-compose@central.service: Failed with result 'exit-code'.
MMM dd hh:mm:ss ***** systemd[1]: Failed to start central via docker-compose.

A post was merged into an existing topic: Installation of ODK Central on Digital Ocean or AWS