Installing application designer: Grunt problem on windows

Hi all,

I'm trying to install the Application Designer. All is fine (Node Js, Android SDK, etc), but I can't get the grunt command to work.

Basically, at the very end of the installation instruction (actually launching it) (http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/). So I follow the instruction to install Grunt (or rather set it to run in system path). See "Grunt install screenshot".

Then, I go to the folder where my Application Designer have been unzipped where Gruntfile.js is, along with index.html & other. I type grunt in the command windows, with command prompt set in the correct directory and I get running grunt screenshot.

If I check in my PATH/environment variables, I don't actually see anything that refers to Grunt. Can I set it manually if that is the problem? What do I need to write for this to work? Or is my problem something else.

Thanks for your time,

Francis

image

image

Ok, nevermind. No sure why but I got it to work. I typed:

npm install -g grunt-cli

You can verify if it actually worked by typing:

grunt --version

I did run it a couple times with right-click "Run as administrator" and other times without. It might have been my problem (though I never got any error message either way).

And then if you set up a cmd shortcut to your Application Designer directory and type "grunt" in that console, it will indeed open up a browser with the Application designer.

Hi Francis,

Have you followed the steps linked here to install grunt?

http://gruntjs.com/getting-started

Make sure you follow the steps to install grunt-cli as well, and then also
the steps in "working with an existing grunt project".

Have you done these steps already?

Sam

··· On Aug 30, 2014 1:43 PM, wrote:

Hi all,

I'm trying to install the Application Designer. All is fine (Node Js,
Android SDK, etc), but I can't get the grunt command to work.

Basically, at the very end of the installation instruction (actually
launching it) (
http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/).
So I follow the instruction to install Grunt (or rather set it to run in
system path). See "Grunt install screenshot".

Then, I go to the folder where my Application Designer have been unzipped
where Gruntfile.js is, along with index.html & other. I type grunt in the
command windows, with command prompt set in the correct directory and I get
running grunt screenshot.

If I check in my PATH/environment variables, I don't actually see anything
that refers to Grunt. Can I set it manually if that is the problem? What do
I need to write for this to work? Or is my problem something else.

Thanks for your time,

Francis

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Ah ok great. =)

··· On Aug 30, 2014 1:59 PM, "Sam Sudar" wrote:

Hi Francis,

Have you followed the steps linked here to install grunt?

http://gruntjs.com/getting-started

Make sure you follow the steps to install grunt-cli as well, and then also
the steps in "working with an existing grunt project".

Have you done these steps already?

Sam
On Aug 30, 2014 1:43 PM, francisvachon.it@gmail.com wrote:

Hi all,

I'm trying to install the Application Designer. All is fine (Node Js,
Android SDK, etc), but I can't get the grunt command to work.

Basically, at the very end of the installation instruction (actually
launching it) (
http://opendatakit.org/use/2_0_tools/odk-application-designer-2-0-rev122/).
So I follow the instruction to install Grunt (or rather set it to run in
system path). See "Grunt install screenshot".

Then, I go to the folder where my Application Designer have been unzipped
where Gruntfile.js is, along with index.html & other. I type grunt in the
command windows, with command prompt set in the correct directory and I get
running grunt screenshot.

If I check in my PATH/environment variables, I don't actually see anything
that refers to Grunt. Can I set it manually if that is the problem? What do
I need to write for this to work? Or is my problem something else.

Thanks for your time,

Francis

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.