Installing on ODK Aggregate on DigitalOcean

1. What is the problem? Be very detailed.
I am installing ODK Aggregate on Digital Ocean as am finding errors messages while uploading my XLSforms that have passed through the sandbox server successfully on Google App Engine.

I am following the step by step guide on ODK for this installation. On Digital Ocean, I am at the step where you need to Set up my Domain and then set a DNS A record pointing to it. I have gone to the FreeDNS to set up a subdomain. Beyond this point, I do not know what to be doing with a TTL setting or how to point the record. I also not sure how to check domain name until I see aggregate load.

However, I went on to Enable HTTPS went to console and ran the following line sudo certbot run --nginx --non-interactive --agree-tos -m YOUR_EMAIL --redirect -d YOUR_DOMAIN. but it said it could not find my command.

2. What app or server are you using and on what device and operating system? Include version numbers.
DigitalOcean to install ODK aggregate

3. What you have you tried to fix the problem?

I tried to open a new subdomain, but am not sure if this is alive and not sure how to check this

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

I am a newbie in this, the technical learning is a steep curve. Thanks


I tried using free domain previously It seems a little complicated. I would suggest, you may try to get a free domain from freenom for free and you can use that for a year.


1 Like

Why don't you install/run ODK on public IP instead of domain name? It is very much workable.

Also, domains are really cheap nowadays. Get a less fancy domain in $5/year or so, and play with it. Shouldn't cost you much and bother you for new learnings, since you already know DNS stuff.

1 Like