Issue with login after installation

1. What is the issue? Please be detailed.
I installed ODK central on Digital Ocean following the instructions on the documentation page. After creating a user, I tried logging in but got a 404 error on the page. I saw a no such file or directory error in the Nginx logs.
nginx_1 | 2022/07/25 09:21:32 [error] 196#196: *2 open() "/usr/share/nginx/html/v1/sessions" failed (2: No such file or directory), client:, server: , request: "POST /v1/sessions HTTP/1.1", host: "odkcentral.xxxxxx.xx", referrer: "https://odkcentral.xxxxxx.xx/"

2. What steps can we take to reproduce this issue?
Install ODK central following the digitalocean instructions from the ODK docs page.
The droplet specs: Docker 19.03.12 on Ubuntu 20.04/2GB Memory/50GB Disk

3. What have you tried to fix the issue?
I tried to reinstall ODK central from scratch twice but I still run into the same issue

4. Upload any test forms or screenshots below.

Look at your service logs with docker logs central_service_1. Any hints as to what has gone wrong?

@yanokwa thank you for your response. I checked the service logs but it didn't have any errors there. This is the full service logs so far: waiting 15 seconds for postgres:5432 postgres:5432 is available after 8 seconds
generating local service configuration..
running migrations..
checking migration success..
starting cron..
using 4 worker(s) based on available memory (2035384)..
starting server.
2022-07-25T09:06:43: PM2 log: Launching in no daemon mode
2022-07-25T09:06:43: PM2 log: App [service:0] starting in -fork mode-
2022-07-25T09:06:43: PM2 log: App [service:0] online