Kobo server reporting 404 not found

Hi @chrissyhroberts and @ggalmazor,

I'm wondering if I am having a similar problem?

I'm using ODK Briefcase v1.12.2 to connect to a kc.kobotoolbox server.

I had been using it up to the weekend with no problem. However, yesterday went to pull the data using the java app for ODK briefcase. The pull happened fine. However, the export failed.

The error it gave was:

Fetching form definition
Unexpected error: Fetch failed. Detailed reason: NOT FOUND (404) while accessing: 

I don't know enough to tell what this error might mean, and if this is something failing with ODK Briefcase, with the Kobo server side, or with the formID?

What I've tried so far:

  • I tried creating a new "ODK Briefcase Storage" in a different folder location
  • I tried exporting to a different export location
  • I tried to use ODK Briefcase v.1.9.0 (Production 2) - however couldn't "pull" at all with that version
  • I opened up the file called cache.ser in ODK Briefcase Storage to see if the formID was in there - it is in there, yes.

I'm at a loss, didn't know if this is a similar problem, or if it's completely different, or if you have workarounds to suggest?

Thanks a million!

Hi @janna!

Looking at the error you've attached, I can't say it has a relation to what @chrissyhroberts has reported.

It looks like something at Kobo's end. Could you, by any chance, have removed the form or changed it so that it has a different formId at Kobo?

That formId looks suspiciously like the 'garbage' filenames that Kobo generates when you do a "Download XML" operation. Whereas the actual formId which Kobo sets in the XML XForm itself is always

<data id="snapshot_xml">...

So I'd probably look around to see if you've accidentally renamed your XForm id incorrectly somewhere...

Hmmm, okay - thanks both @Xiphware and @ggalmazor.

I'll see if people on the Kobo end have any idea what's going on, as I'm not sure how they assign Xform id's, or how to change them, etc.

1 Like