Not possible to create new users due to; invalid host header

1. What is the issue? Please be detailed.
It started with creating new users in web-ODKcentral users dont recieve an email, also via reset password no email is send. However after this we found two major errors; "invalid Host header" and "odk-cmd" is not running container #1 anny ideas on how to resolve would be very welcome as we intend to start data collection tomorow! being able to use: docker-compose exec service odk-cmd --email YOUREMAIL@ADDRESSHERE.com user-create ASAP would be of huge help.

2. What steps can we take to reproduce this issue?

3. What have you tried to fix the issue?

  1. run docker-compose ps and t shows that "mail" is in an up state
  2. docker-compose exec service odk-cmd --email YOUREMAIL@ADDRESSHERE.com user-create -> but we get the invalid host header error
  3. Run: docker-compose logs --tail 50 service and docker-compose logs --tail 50 mail This appears to show mail delivery attempts and deferment due to a retry time not being reached for the specified hosts.
  4. tried to set-up a custom provider but ran into host header and odk-cmd not running problems.

4. Upload any forms or screenshots you can share publicly below.

Thanks in advance!

Is this a new install or an old install that has recently developed this problem? What do you have as the DOMAIN in .env?

Hi @yanokwa Thanks!

versions:
v2023.3.1-2-g66a517b
v2023.3.0)
v2023.3.1

Make sure you are running Docker Engine v23.x and Docker Compose v2.16.x or greater.

docker --version && docker compose version

If you running the correct versions, note that the command to create users does not start with docker-compose exec service odk-cmd, it starts with docker compose exec service odk-cmd. There is a space between docker and compose.