November 10th: ODK Build will not be able to automatically upload forms to ODK Aggregate

If you got an e-mail from Google with the content below, you should be
aware that the automatic uploading of forms into ODK Aggregate from ODK
Build will cease to function as of November 10th.

The work-around is to download the form XML to your computer then manually
upload that to ODK Aggregate.

=========warning e-mail from Google============

Dear App Engine Customer,

You are receiving this email because you are listed as an owner of a Google
App Engine application that uses the deprecated OAuth 1.0 API.

Google App Engine deprecated
https://cloud.google.com/appengine/docs/deprecations/oauth1 our Alpha
OAuth 1.0 API on July 14, 2015, in order to focus support on OAuth 2.0
which increases security and reduces complexity for developers. We will
fully turn down this API on November 10th, 2015.

Please note that no extensions to this date will be possible. If you do not
migrate your application off OAuth 1.0 beforeNovember 10, 2015, your
application will experience an outage in its ability to connect to Google
(possibly including the ability to sign in) until you migrate your
application.

We strongly encourage developers to start switching over to OAuth 2.0
today. See the App Engine OAuth documentation (Python
https://cloud.google.com/appengine/docs/python/oauth/#Python_OAuth_and_App_Engine
, Java
https://cloud.google.com/appengine/docs/java/oauth/#Java_OAuth_and_App_Engine
, Go
https://cloud.google.com/appengine/docs/go/oauth/#Go_OAuth_and_App_Engine)
for instructions on how to use OAuth 2.0 in your application.

Below is the list of applications that you are an owner of that are using
OAuth 1.0:
s~your-application-id

For more information please read OAuth 1.0 service shutdown documentation
https://cloud.google.com/appengine/docs/deprecations/oauth1.

If you have any questions regarding this communication, you can reach us
via this support form
https://support.google.com/cloud/contact/oauth1_api_deprecation.

Regards,

The Google Cloud Platform Team

---- © 2015 Google Inc. 1600 Amphitheatre Parkway, Mountain View, CA 94043

You have received this mandatory email service announcement to update you
about important changes to Google Cloud Platform or your account.

··· ================================== -- Mitch Sundt Software Engineer University of Washington mitchellsundt@gmail.com

Hi Mitch,
Thanks for the note! Do we need to do anything to our forms and the data?
Wen

··· On Wednesday, September 23, 2015 at 3:37:37 PM UTC-4, Mitch Sundt wrote: > > If you got an e-mail from Google with the content below, you should be > aware that the automatic uploading of forms into ODK Aggregate from ODK > Build will cease to function as of November 10th. > > The work-around is to download the form XML to your computer then manually > upload that to ODK Aggregate. > > =========warning e-mail from Google============ > > Dear App Engine Customer, > > You are receiving this email because you are listed as an owner of a > Google App Engine application that uses the deprecated OAuth 1.0 API. > > Google App Engine deprecated > our Alpha > OAuth 1.0 API on July 14, 2015, in order to focus support on OAuth 2.0 > which increases security and reduces complexity for developers. We will > fully turn down this API on *November 10th, 2015*. > > Please note that no extensions to this date will be possible. If you do > not migrate your application off OAuth 1.0 beforeNovember 10, 2015, your > application will experience an outage in its ability to connect to Google > (possibly including the ability to sign in) until you migrate your > application. > > We strongly encourage developers to start switching over to OAuth 2.0 > today. See the App Engine OAuth documentation (Python > > , Java > > , Go > ) > for instructions on how to use OAuth 2.0 in your application. > > Below is the list of applications that you are an owner of that are using > OAuth 1.0: > *s~your-application-id* > > For more information please read OAuth 1.0 service shutdown documentation > . > > If you have any questions regarding this communication, you can reach us > via this support form > . > > Regards, > > The Google Cloud Platform Team > > ---- © 2015 Google Inc. 1600 Amphitheatre Parkway, Mountain View, CA 94043 > > You have received this mandatory email service announcement to update you > about important changes to Google Cloud Platform or your account. > ================================== > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >

No, this just affects the automatic publishing of forms from ODK Build into
ODK Aggregate.

··· On Thu, Oct 22, 2015 at 1:24 PM, Wen wrote:

Hi Mitch,
Thanks for the note! Do we need to do anything to our forms and the data?
Wen

On Wednesday, September 23, 2015 at 3:37:37 PM UTC-4, Mitch Sundt wrote:

If you got an e-mail from Google with the content below, you should be
aware that the automatic uploading of forms into ODK Aggregate from ODK
Build will cease to function as of November 10th.

The work-around is to download the form XML to your computer then
manually upload that to ODK Aggregate.

=========warning e-mail from Google============

Dear App Engine Customer,

You are receiving this email because you are listed as an owner of a
Google App Engine application that uses the deprecated OAuth 1.0 API.

Google App Engine deprecated
https://cloud.google.com/appengine/docs/deprecations/oauth1 our Alpha
OAuth 1.0 API on July 14, 2015, in order to focus support on OAuth 2.0
which increases security and reduces complexity for developers. We will
fully turn down this API on November 10th, 2015.

Please note that no extensions to this date will be possible. If you do
not migrate your application off OAuth 1.0 beforeNovember 10, 2015, your
application will experience an outage in its ability to connect to Google
(possibly including the ability to sign in) until you migrate your
application.

We strongly encourage developers to start switching over to OAuth 2.0
today. See the App Engine OAuth documentation (Python
https://cloud.google.com/appengine/docs/python/oauth/#Python_OAuth_and_App_Engine
, Java
https://cloud.google.com/appengine/docs/java/oauth/#Java_OAuth_and_App_Engine
, Go
https://cloud.google.com/appengine/docs/go/oauth/#Go_OAuth_and_App_Engine)
for instructions on how to use OAuth 2.0 in your application.

Below is the list of applications that you are an owner of that are using
OAuth 1.0:
s~your-application-id

For more information please read OAuth 1.0 service shutdown documentation
https://cloud.google.com/appengine/docs/deprecations/oauth1.

If you have any questions regarding this communication, you can reach us
via this support form
https://support.google.com/cloud/contact/oauth1_api_deprecation.

Regards,

The Google Cloud Platform Team

---- © 2015 Google Inc. 1600 Amphitheatre Parkway, Mountain View, CA
94043

You have received this mandatory email service announcement to update you
about important changes to Google Cloud Platform or your account.

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com