Odk 2.0 previously created instances question

I have 2 tables apps that run 2 different surveys one survey in each tables app. In one case when the survey comes up it shows previously created instances on the survey start screen and in the other tables app it does not. Is this something that needs to be set, and if so where is it set? In both cases application designer shows the created instances on the survey screen but on the device one shows the created instances the other does not.

Thanks.

When you say that you have two different Tables apps, do you mean that you
have the Tables apps configured like we do in our Tables demo chooser app?
I've attached a screenshot for your reference. In the demo app, the tabs
at the top let you launch the Tea Time, Hope, Plot, Geotagger, or JGI
demo. How are you launching Survey? Are you always launching into the
initial screen or are you skipping the initial section? Please provide
more detail. Also, if appropriate, please send along any attachments that
could clarify the issue.

Thanks,
Clarice

··· On Wed, Oct 7, 2015 at 4:18 PM, <7shriner@gmail.com> wrote:

I have 2 tables apps that run 2 different surveys one survey in each
tables app. In one case when the survey comes up it shows previously
created instances on the survey start screen and in the other tables app it
does not. Is this something that needs to be set, and if so where is it
set? In both cases application designer shows the created instances on the
survey screen but on the device one shows the created instances the other
does not.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Sorry for confusion. I have 2 entirley seperate tables apps each with an entirley different survey each on different aggregate instances.

To answer your question:
How are you launching Survey? Are you always launching into the initial screen or are you skipping the initial section?

I am not really sure. Part of my question is how that part actually works. Is that documented an where ? That is probably the issue - I don't have something setup right but I am not sure how it is supposed to be set up.

I think both apps go to the "initial screen" (although I am not sure of the exact definition of initial screen). They go to the spreadsheet view where you can press + to go to survey or select an instance from the spreadsheet.

In one tables app when it gets to the survey landing page (the page where survey starts - where the logo is, etc..) it shows all the instances. In my other tables app it does not.

Thanks.

··· On Wednesday, October 7, 2015 at 6:18:32 PM UTC-5, 7shr...@gmail.com wrote: > I have 2 tables apps that run 2 different surveys one survey in each tables app. In one case when the survey comes up it shows previously created instances on the survey start screen and in the other tables app it does not. Is this something that needs to be set, and if so where is it set? In both cases application designer shows the created instances on the survey screen but on the device one shows the created instances the other does not. > > Thanks.

It sounds like you have followed the directions at
https://opendatakit.org/use/2_0_tools/odk-survey-2-0-rev126/#Launching_AppName
to launch Tables using the context of a different app name under the
/sdcard/opendatakit directory. If this is the case, it is possible that
when you are launching Survey from Tables, the database being used is the
database under the /sdcard/opendatakit/tables directory and not the
database under /sdcard/opendatakit/ directory that corresponds to your app
name.

It sounds like you are seeing the initial screen and not launching directly
into a survey as you are able to show all the instances for that survey.

There are a few ways to launch Survey from Tables. This can be done in the
JavaScript using the control interface (an example function would be
control.addRowWithSurvey). You can look at the JavaScript code for our
demo apps in the app-designer repo for more examples. This can also be
done in Tables by going to the settings for the table that you are
interested in and changing the Default Form to launch the appropriate
Survey form.

If you have more questions, I can provide more insightful answers if you
send me the opendatakit directories of both of your Tables apps.

Clarice

··· On Sat, Oct 10, 2015 at 5:43 AM, <7shriner@gmail.com> wrote:

On Wednesday, October 7, 2015 at 6:18:32 PM UTC-5, 7shr...@gmail.com wrote:

I have 2 tables apps that run 2 different surveys one survey in each
tables app. In one case when the survey comes up it shows previously
created instances on the survey start screen and in the other tables app it
does not. Is this something that needs to be set, and if so where is it
set? In both cases application designer shows the created instances on the
survey screen but on the device one shows the created instances the other
does not.

Thanks.

Sorry for confusion. I have 2 entirley seperate tables apps each with an
entirley different survey each on different aggregate instances.

To answer your question:
How are you launching Survey? Are you always launching into the initial
screen or are you skipping the initial section?

I am not really sure. Part of my question is how that part actually works.
Is that documented an where ? That is probably the issue - I don't have
something setup right but I am not sure how it is supposed to be set up.

I think both apps go to the "initial screen" (although I am not sure of
the exact definition of initial screen). They go to the spreadsheet view
where you can press + to go to survey or select an instance from the
spreadsheet.

In one tables app when it gets to the survey landing page (the page where
survey starts - where the logo is, etc..) it shows all the instances. In my
other tables app it does not.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.