ODK Aggregate Data Submission don't display correctly

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I found that
the ODK Aggregate show question mark (???) on data field of Unicode string.
Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

I'm assuming ODK Aggregate displays the data correctly, but when you
export to CSV it doesn't work. If that assumption is correct see
https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ.
If that assumption is not correct, then clarify what platform (Tomcat?
GAE?) and database (MySQL? PostgreSQL) you are using.

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou bunhann@gmail.com wrote:

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I found that the
ODK Aggregate show question mark (???) on data field of Unicode string.
Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Dear Yaw,

Thanks for your information. But let me clarify with you about my my
assumption. I use Tomcat6 and MySQL 5.6.
I'm sure that the ODK Aggregate get data correctly but it doesn't display
well or unable to recognize the Unicode character. Please have a look with
my attachment.
Please help me with this,

Regards,

··· On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: > > I'm assuming ODK Aggregate displays the data correctly, but when you > export to CSV it doesn't work. If that assumption is correct see > https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ. > > If that assumption is not correct, then clarify what platform (Tomcat? > GAE?) and database (MySQL? PostgreSQL) you are using. > > Yaw > -- > Need ODK services? http://nafundi.com provides form design, server > setup, professional support, and software development for ODK. > > On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou <bun...@gmail.com> wrote: > > Dear ODK experience users and developer, > > > > I found out some problems while i try to use Open Data Kit. I found that > the > > ODK Aggregate show question mark (???) on data field of Unicode string. > > Example: > > - On ODK Collect: I enter this string "បាទ". When We submit to > Aggregate. > > - On ODK Aggregate: It doesn't show string correctly. > > > > Any one experience in this problem, please help me. > > > > -- > > You received this message because you are subscribed to the Google > Groups > > "ODK Developers" group. > > To unsubscribe from this group and stop receiving emails from it, send > an > > email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout. >

Can you try the same form on a test Google App Engine instance? My
guess is that your MySQL was set up with no (or non-standard) unicode
support.

Yaw

··· On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou wrote: > Dear Yaw, > > Thanks for your information. But let me clarify with you about my my > assumption. I use Tomcat6 and MySQL 5.6. > I'm sure that the ODK Aggregate get data correctly but it doesn't display > well or unable to recognize the Unicode character. Please have a look with > my attachment. > Please help me with this, > > Regards, > > > On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: >> >> I'm assuming ODK Aggregate displays the data correctly, but when you >> export to CSV it doesn't work. If that assumption is correct see >> >> https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ. >> If that assumption is not correct, then clarify what platform (Tomcat? >> GAE?) and database (MySQL? PostgreSQL) you are using. >> >> Yaw >> -- >> Need ODK services? http://nafundi.com provides form design, server >> setup, professional support, and software development for ODK. >> >> On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou wrote: >> > Dear ODK experience users and developer, >> > >> > I found out some problems while i try to use Open Data Kit. I found that >> > the >> > ODK Aggregate show question mark (???) on data field of Unicode string. >> > Example: >> > - On ODK Collect: I enter this string "បាទ". When We submit to >> > Aggregate. >> > - On ODK Aggregate: It doesn't show string correctly. >> > >> > Any one experience in this problem, please help me. >> > >> > -- >> > You received this message because you are subscribed to the Google >> > Groups >> > "ODK Developers" group. >> > To unsubscribe from this group and stop receiving emails from it, send >> > an >> > email to opendatakit-developers+unsubscribe@googlegroups.com. >> > For more options, visit https://groups.google.com/d/optout. > > -- > You received this message because you are subscribed to the Google Groups > "ODK Developers" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to opendatakit-developers+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/d/optout.

As detailed in the "Select and Install Database Server" section here:
http://opendatakit.org/use/aggregate/tomcat-install/

"For either database, you should ensure that the default character set is
configured to be UTF-8 and that the collation sequence (dictionary order)
is set appropriately for your circumstances. If it isn't, any non-Latin
characters may display as question marks. Refer to the character set and
collation sections of your database's documentation for how to do this."

··· On Thu, Apr 24, 2014 at 10:13 AM, Yaw Anokwa wrote:

Can you try the same form on a test Google App Engine instance? My
guess is that your MySQL was set up with no (or non-standard) unicode
support.

Yaw

On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou bunhann@gmail.com wrote:

Dear Yaw,

Thanks for your information. But let me clarify with you about my my
assumption. I use Tomcat6 and MySQL 5.6.
I'm sure that the ODK Aggregate get data correctly but it doesn't display
well or unable to recognize the Unicode character. Please have a look
with
my attachment.
Please help me with this,

Regards,

On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote:

I'm assuming ODK Aggregate displays the data correctly, but when you
export to CSV it doesn't work. If that assumption is correct see

https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ
.

If that assumption is not correct, then clarify what platform (Tomcat?
GAE?) and database (MySQL? PostgreSQL) you are using.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou bun...@gmail.com wrote:

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I found
that

the
ODK Aggregate show question mark (???) on data field of Unicode
string.

Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to
    Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Dear Yaw,

Thanks for your response. You are right, I try with my Google App Engine,
it works fine for me but do you have any solution to help me on MySQL
server because i already change my MySQL database to support non-latin
character but it still display the data as question marks (???). Do we need
to change something on ODK Aggregate? Or something else? Please help me.

Regards,

··· On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote: > > Can you try the same form on a test Google App Engine instance? My > guess is that your MySQL was set up with no (or non-standard) unicode > support. > > Yaw > > On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou <bun...@gmail.com> wrote: > > Dear Yaw, > > > > Thanks for your information. But let me clarify with you about my my > > assumption. I use Tomcat6 and MySQL 5.6. > > I'm sure that the ODK Aggregate get data correctly but it doesn't > display > > well or unable to recognize the Unicode character. Please have a look > with > > my attachment. > > Please help me with this, > > > > Regards, > > > > > > On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: > >> > >> I'm assuming ODK Aggregate displays the data correctly, but when you > >> export to CSV it doesn't work. If that assumption is correct see > >> > >> > https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ. > > >> If that assumption is not correct, then clarify what platform (Tomcat? > >> GAE?) and database (MySQL? PostgreSQL) you are using. > >> > >> Yaw > >> -- > >> Need ODK services? http://nafundi.com provides form design, server > >> setup, professional support, and software development for ODK. > >> > >> On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou wrote: > >> > Dear ODK experience users and developer, > >> > > >> > I found out some problems while i try to use Open Data Kit. I found > that > >> > the > >> > ODK Aggregate show question mark (???) on data field of Unicode > string. > >> > Example: > >> > - On ODK Collect: I enter this string "បាទ". When We submit to > >> > Aggregate. > >> > - On ODK Aggregate: It doesn't show string correctly. > >> > > >> > Any one experience in this problem, please help me. > >> > > >> > -- > >> > You received this message because you are subscribed to the Google > >> > Groups > >> > "ODK Developers" group. > >> > To unsubscribe from this group and stop receiving emails from it, > send > >> > an > >> > email to opendatakit-developers+unsubscribe@googlegroups.com. > > >> > For more options, visit https://groups.google.com/d/optout. > > > > -- > > You received this message because you are subscribed to the Google > Groups > > "ODK Developers" group. > > To unsubscribe from this group and stop receiving emails from it, send > an > > email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout. >

Dear Yaw,

I face the same problem with Bunhann (khmer unicode not support).

  • I import create_db_and_user.sql to mySql database then I change the database collation such as; utf8_bin, utf8_unicode_ci
  • I deploy ODKAggregate.war in my tomcat
  • My OS is Ubuntu 14

is it correct what I have done? but it still show "??" when I summit from ODK collect.

can u show me how to set up mySql with unicode support? google app engine work fine.

Regards,

··· On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote: > Can you try the same form on a test Google App Engine instance? My > > guess is that your MySQL was set up with no (or non-standard) unicode > > support. > > > > Yaw > > > > On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou wrote: > > > Dear Yaw, > > > > > > Thanks for your information. But let me clarify with you about my my > > > assumption. I use Tomcat6 and MySQL 5.6. > > > I'm sure that the ODK Aggregate get data correctly but it doesn't display > > > well or unable to recognize the Unicode character. Please have a look with > > > my attachment. > > > Please help me with this, > > > > > > Regards, > > > > > > > > > On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: > > >> > > >> I'm assuming ODK Aggregate displays the data correctly, but when you > > >> export to CSV it doesn't work. If that assumption is correct see > > >> > > >> https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ. > > >> If that assumption is not correct, then clarify what platform (Tomcat? > > >> GAE?) and database (MySQL? PostgreSQL) you are using. > > >> > > >> Yaw > > >> -- > > >> Need ODK services? http://nafundi.com provides form design, server > > >> setup, professional support, and software development for ODK. > > >> > > >> On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou wrote: > > >> > Dear ODK experience users and developer, > > >> > > > >> > I found out some problems while i try to use Open Data Kit. I found that > > >> > the > > >> > ODK Aggregate show question mark (???) on data field of Unicode string. > > >> > Example: > > >> > - On ODK Collect: I enter this string "បាទ". When We submit to > > >> > Aggregate. > > >> > - On ODK Aggregate: It doesn't show string correctly. > > >> > > > >> > Any one experience in this problem, please help me. > > >> > > > >> > -- > > >> > You received this message because you are subscribed to the Google > > >> > Groups > > >> > "ODK Developers" group. > > >> > To unsubscribe from this group and stop receiving emails from it, send > > >> > an > > >> > email to opendatakit-developers+unsubscribe@googlegroups.com. > > >> > For more options, visit https://groups.google.com/d/optout. > > > > > > -- > > > You received this message because you are subscribed to the Google Groups > > > "ODK Developers" group. > > > To unsubscribe from this group and stop receiving emails from it, send an > > > email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout.

Dear Mitch,

Thanks for your information. But I already change collation of MySQL server
to support non-Latin characters but it still display as questions marks. Do
you have any idea or any advice to guide me on put collation of MySQL
database.

Regards,

··· On Friday, April 25, 2014 12:17:52 AM UTC+7, Mitch wrote: > > As detailed in the "Select and Install Database Server" section here: > http://opendatakit.org/use/aggregate/tomcat-install/ > > "For either database, you should ensure that the default character set is > configured to be UTF-8 and that the collation sequence (dictionary order) > is set appropriately for your circumstances. If it isn't, any non-Latin > characters may display as question marks. Refer to the character set and > collation sections of your database's documentation for how to do this." > > > On Thu, Apr 24, 2014 at 10:13 AM, Yaw Anokwa <yan...@nafundi.com wrote: > >> Can you try the same form on a test Google App Engine instance? My >> guess is that your MySQL was set up with no (or non-standard) unicode >> support. >> >> Yaw >> >> On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou <bun...@gmail.com> wrote: >> > Dear Yaw, >> > >> > Thanks for your information. But let me clarify with you about my my >> > assumption. I use Tomcat6 and MySQL 5.6. >> > I'm sure that the ODK Aggregate get data correctly but it doesn't >> display >> > well or unable to recognize the Unicode character. Please have a look >> with >> > my attachment. >> > Please help me with this, >> > >> > Regards, >> > >> > >> > On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: >> >> >> >> I'm assuming ODK Aggregate displays the data correctly, but when you >> >> export to CSV it doesn't work. If that assumption is correct see >> >> >> >> >> https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ >> . >> >> If that assumption is not correct, then clarify what platform (Tomcat? >> >> GAE?) and database (MySQL? PostgreSQL) you are using. >> >> >> >> Yaw >> >> -- >> >> Need ODK services? http://nafundi.com provides form design, server >> >> setup, professional support, and software development for ODK. >> >> >> >> On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou wrote: >> >> > Dear ODK experience users and developer, >> >> > >> >> > I found out some problems while i try to use Open Data Kit. I found >> that >> >> > the >> >> > ODK Aggregate show question mark (???) on data field of Unicode >> string. >> >> > Example: >> >> > - On ODK Collect: I enter this string "បាទ". When We submit to >> >> > Aggregate. >> >> > - On ODK Aggregate: It doesn't show string correctly. >> >> > >> >> > Any one experience in this problem, please help me. >> >> > >> >> > -- >> >> > You received this message because you are subscribed to the Google >> >> > Groups >> >> > "ODK Developers" group. >> >> > To unsubscribe from this group and stop receiving emails from it, >> send >> >> > an >> >> > email to opendatakit-developers+unsubscribe@googlegroups.com >> . >> >> > For more options, visit https://groups.google.com/d/optout. >> > >> > -- >> > You received this message because you are subscribed to the Google >> Groups >> > "ODK Developers" group. >> > To unsubscribe from this group and stop receiving emails from it, send >> an >> > email to opendatakit-developers+unsubscribe@googlegroups.com >> . >> > For more options, visit https://groups.google.com/d/optout. >> >> -- >> You received this message because you are subscribed to the Google Groups >> "ODK Developers" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit-developers+unsubscribe@googlegroups.com >> . >> For more options, visit https://groups.google.com/d/optout. >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >

The problem is in MySQL so you have to fix the problem in MySQL's
settings and probably the tables themselves. If you can start over, my
recommendation is to start over on your Aggregate install.

In my /etc/mysql/conf.d/utf8_charset.cnf on Ubuntu, I have the following...

[mysqld]
character-set-server=utf8
collation-server=utf8_unicode_ci
init-connect='SET collation_connection=utf8_unicode_ci'

[client]
default-character-set=utf8

If you can't start over, then you can try something like this


in the tables, but I have no idea if that will actually work. Might
even make things worse.

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Thu, Apr 24, 2014 at 8:27 PM, Bunhann Thou bunhann@gmail.com wrote:

Dear Yaw,

Thanks for your response. You are right, I try with my Google App Engine, it
works fine for me but do you have any solution to help me on MySQL server
because i already change my MySQL database to support non-latin character
but it still display the data as question marks (???). Do we need to change
something on ODK Aggregate? Or something else? Please help me.

Regards,

On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote:

Can you try the same form on a test Google App Engine instance? My
guess is that your MySQL was set up with no (or non-standard) unicode
support.

Yaw

On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou bun...@gmail.com wrote:

Dear Yaw,

Thanks for your information. But let me clarify with you about my my
assumption. I use Tomcat6 and MySQL 5.6.
I'm sure that the ODK Aggregate get data correctly but it doesn't
display
well or unable to recognize the Unicode character. Please have a look
with
my attachment.
Please help me with this,

Regards,

On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote:

I'm assuming ODK Aggregate displays the data correctly, but when you
export to CSV it doesn't work. If that assumption is correct see

https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ.
If that assumption is not correct, then clarify what platform (Tomcat?
GAE?) and database (MySQL? PostgreSQL) you are using.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou bun...@gmail.com wrote:

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I found
that
the
ODK Aggregate show question mark (???) on data field of Unicode
string.
Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to
    Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Dear Yaw,

Thanks for your help. I try to find the file on
/etc/mysql/conf.d/utf8_charset.cnf on my ubuntu but i cannot find it.
I try to change the database server to PostgreSQL and it works fine but i
still don't understand with MySQL database.
Please help me to figure out this,

Thanks.

··· On Friday, April 25, 2014 11:02:05 AM UTC+7, Yaw Anokwa wrote: > > The problem is in MySQL so you have to fix the problem in MySQL's > settings and probably the tables themselves. If you can start over, my > recommendation is to start over on your Aggregate install. > > In my /etc/mysql/conf.d/utf8_charset.cnf on Ubuntu, I have the > following... > > [mysqld] > character-set-server=utf8 > collation-server=utf8_unicode_ci > init-connect='SET collation_connection=utf8_unicode_ci' > > [client] > default-character-set=utf8 > > If you can't start over, then you can try something like this > > http://stackoverflow.com/questions/4070642/converting-mysql-tables-from-latin1-to-utf8 > in the tables, but I have no idea if that will actually work. Might > even make things worse. > > Yaw > -- > Need ODK services? http://nafundi.com provides form design, server > setup, professional support, and software development for ODK. > > On Thu, Apr 24, 2014 at 8:27 PM, Bunhann Thou <bun...@gmail.com> wrote: > > Dear Yaw, > > > > Thanks for your response. You are right, I try with my Google App > Engine, it > > works fine for me but do you have any solution to help me on MySQL > server > > because i already change my MySQL database to support non-latin > character > > but it still display the data as question marks (???). Do we need to > change > > something on ODK Aggregate? Or something else? Please help me. > > > > Regards, > > > > > > > > On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote: > >> > >> Can you try the same form on a test Google App Engine instance? My > >> guess is that your MySQL was set up with no (or non-standard) unicode > >> support. > >> > >> Yaw > >> > >> On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou wrote: > >> > Dear Yaw, > >> > > >> > Thanks for your information. But let me clarify with you about my my > >> > assumption. I use Tomcat6 and MySQL 5.6. > >> > I'm sure that the ODK Aggregate get data correctly but it doesn't > >> > display > >> > well or unable to recognize the Unicode character. Please have a look > >> > with > >> > my attachment. > >> > Please help me with this, > >> > > >> > Regards, > >> > > >> > > >> > On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote: > >> >> > >> >> I'm assuming ODK Aggregate displays the data correctly, but when you > >> >> export to CSV it doesn't work. If that assumption is correct see > >> >> > >> >> > >> >> > https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ. > > >> >> If that assumption is not correct, then clarify what platform > (Tomcat? > >> >> GAE?) and database (MySQL? PostgreSQL) you are using. > >> >> > >> >> Yaw > >> >> -- > >> >> Need ODK services? http://nafundi.com provides form design, server > >> >> setup, professional support, and software development for ODK. > >> >> > >> >> On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou wrote: > >> >> > Dear ODK experience users and developer, > >> >> > > >> >> > I found out some problems while i try to use Open Data Kit. I > found > >> >> > that > >> >> > the > >> >> > ODK Aggregate show question mark (???) on data field of Unicode > >> >> > string. > >> >> > Example: > >> >> > - On ODK Collect: I enter this string "បាទ". When We submit to > >> >> > Aggregate. > >> >> > - On ODK Aggregate: It doesn't show string correctly. > >> >> > > >> >> > Any one experience in this problem, please help me. > >> >> > > >> >> > -- > >> >> > You received this message because you are subscribed to the Google > >> >> > Groups > >> >> > "ODK Developers" group. > >> >> > To unsubscribe from this group and stop receiving emails from it, > >> >> > send > >> >> > an > >> >> > email to opendatakit-developers+unsubscribe@googlegroups.com. > > >> >> > For more options, visit https://groups.google.com/d/optout. > >> > > >> > -- > >> > You received this message because you are subscribed to the Google > >> > Groups > >> > "ODK Developers" group. > >> > To unsubscribe from this group and stop receiving emails from it, > send > >> > an > >> > email to opendatakit-developers+unsubscribe@googlegroups.com. > > >> > For more options, visit https://groups.google.com/d/optout. > > > > -- > > You received this message because you are subscribed to the Google > Groups > > "ODK Developers" group. > > To unsubscribe from this group and stop receiving emails from it, send > an > > email to opendatakit-developers+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/d/optout. >

The help I've provided already is about the best I can offer. Perhaps
ask for more guidance on a MySQL forum.

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Fri, Apr 25, 2014 at 4:41 AM, Bunhann Thou bunhann@gmail.com wrote:

Dear Yaw,

Thanks for your help. I try to find the file on
/etc/mysql/conf.d/utf8_charset.cnf on my ubuntu but i cannot find it.
I try to change the database server to PostgreSQL and it works fine but i
still don't understand with MySQL database.
Please help me to figure out this,

Thanks.

On Friday, April 25, 2014 11:02:05 AM UTC+7, Yaw Anokwa wrote:

The problem is in MySQL so you have to fix the problem in MySQL's
settings and probably the tables themselves. If you can start over, my
recommendation is to start over on your Aggregate install.

In my /etc/mysql/conf.d/utf8_charset.cnf on Ubuntu, I have the
following...

[mysqld]
character-set-server=utf8
collation-server=utf8_unicode_ci
init-connect='SET collation_connection=utf8_unicode_ci'

[client]
default-character-set=utf8

If you can't start over, then you can try something like this

http://stackoverflow.com/questions/4070642/converting-mysql-tables-from-latin1-to-utf8
in the tables, but I have no idea if that will actually work. Might
even make things worse.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Thu, Apr 24, 2014 at 8:27 PM, Bunhann Thou bun...@gmail.com wrote:

Dear Yaw,

Thanks for your response. You are right, I try with my Google App
Engine, it
works fine for me but do you have any solution to help me on MySQL
server
because i already change my MySQL database to support non-latin
character
but it still display the data as question marks (???). Do we need to
change
something on ODK Aggregate? Or something else? Please help me.

Regards,

On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote:

Can you try the same form on a test Google App Engine instance? My
guess is that your MySQL was set up with no (or non-standard) unicode
support.

Yaw

On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou bun...@gmail.com wrote:

Dear Yaw,

Thanks for your information. But let me clarify with you about my my
assumption. I use Tomcat6 and MySQL 5.6.
I'm sure that the ODK Aggregate get data correctly but it doesn't
display
well or unable to recognize the Unicode character. Please have a look
with
my attachment.
Please help me with this,

Regards,

On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote:

I'm assuming ODK Aggregate displays the data correctly, but when you
export to CSV it doesn't work. If that assumption is correct see

https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ.
If that assumption is not correct, then clarify what platform
(Tomcat?
GAE?) and database (MySQL? PostgreSQL) you are using.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou bun...@gmail.com wrote:

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I
found
that
the
ODK Aggregate show question mark (???) on data field of Unicode
string.
Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to
    Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

The database engine -- what you set up when you install MySQL -- is
probably not configured for UTF-8. I assume this is a database that is only
used by ODK Aggregate.

Look in the my.ini file, in the base directory of your MySQL install (
C:\Program Files\MySQL\MySQL Server 5.x\ ).

Verify that the lines in *bold *are present and set accordingly (the file
is much bigger than this -- this is only a small portion):

...

··· # [client]

port=3306

[mysql]

default-character-set=utf8
mysqld]

max_allowed_packet=256M

The TCP/IP Port the MySQL Server will listen on

port=3306

#Path to installation directory. All paths are usually resolved relative to
this.
basedir="C:/Program Files/MySQL/MySQL Server 5.5/"

#Path to the database root
datadir="C:/ProgramData/MySQL/MySQL Server 5.5/Data/"

The default character set that will be used when a new schema or table is

created and no character set is defined

character-set-server=utf8

The default storage engine that will be used when create new tables when


You will likely need to stop and restart the server to make these changes.

On Fri, Apr 25, 2014 at 7:22 AM, Yaw Anokwa yanokwa@nafundi.com wrote:

The help I've provided already is about the best I can offer. Perhaps
ask for more guidance on a MySQL forum.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Fri, Apr 25, 2014 at 4:41 AM, Bunhann Thou bunhann@gmail.com wrote:

Dear Yaw,

Thanks for your help. I try to find the file on
/etc/mysql/conf.d/utf8_charset.cnf on my ubuntu but i cannot find it.
I try to change the database server to PostgreSQL and it works fine but i
still don't understand with MySQL database.
Please help me to figure out this,

Thanks.

On Friday, April 25, 2014 11:02:05 AM UTC+7, Yaw Anokwa wrote:

The problem is in MySQL so you have to fix the problem in MySQL's
settings and probably the tables themselves. If you can start over, my
recommendation is to start over on your Aggregate install.

In my /etc/mysql/conf.d/utf8_charset.cnf on Ubuntu, I have the
following...

[mysqld]
character-set-server=utf8
collation-server=utf8_unicode_ci
init-connect='SET collation_connection=utf8_unicode_ci'

[client]
default-character-set=utf8

If you can't start over, then you can try something like this

http://stackoverflow.com/questions/4070642/converting-mysql-tables-from-latin1-to-utf8

in the tables, but I have no idea if that will actually work. Might
even make things worse.

Yaw

Need ODK services? http://nafundi.com provides form design, server
setup, professional support, and software development for ODK.

On Thu, Apr 24, 2014 at 8:27 PM, Bunhann Thou bun...@gmail.com wrote:

Dear Yaw,

Thanks for your response. You are right, I try with my Google App
Engine, it
works fine for me but do you have any solution to help me on MySQL
server
because i already change my MySQL database to support non-latin
character
but it still display the data as question marks (???). Do we need to
change
something on ODK Aggregate? Or something else? Please help me.

Regards,

On Friday, April 25, 2014 12:13:02 AM UTC+7, Yaw Anokwa wrote:

Can you try the same form on a test Google App Engine instance? My
guess is that your MySQL was set up with no (or non-standard) unicode
support.

Yaw

On Thu, Apr 24, 2014 at 2:36 AM, Bunhann Thou bun...@gmail.com wrote:

Dear Yaw,

Thanks for your information. But let me clarify with you about my
my

assumption. I use Tomcat6 and MySQL 5.6.
I'm sure that the ODK Aggregate get data correctly but it doesn't
display
well or unable to recognize the Unicode character. Please have a
look

with
my attachment.
Please help me with this,

Regards,

On Wednesday, April 23, 2014 11:33:58 PM UTC+7, Yaw Anokwa wrote:

I'm assuming ODK Aggregate displays the data correctly, but when
you

export to CSV it doesn't work. If that assumption is correct see

https://groups.google.com/forum/#!msg/opendatakit/Xh4r6ibFKlE/RZz2E0N-mTQJ
.

If that assumption is not correct, then clarify what platform
(Tomcat?
GAE?) and database (MySQL? PostgreSQL) you are using.

Yaw

Need ODK services? http://nafundi.com provides form design,
server

setup, professional support, and software development for ODK.

On Wed, Apr 23, 2014 at 3:14 AM, Bunhann Thou bun...@gmail.com wrote:

Dear ODK experience users and developer,

I found out some problems while i try to use Open Data Kit. I
found
that
the
ODK Aggregate show question mark (???) on data field of Unicode
string.
Example:

  • On ODK Collect: I enter this string "បាទ". When We submit to
    Aggregate.
  • On ODK Aggregate: It doesn't show string correctly.

Any one experience in this problem, please help me.

--
You received this message because you are subscribed to the
Google

Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from
it,

send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it,
send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com