ODK Aggregate v1.6 Beta

We need your help to ship great software, so please download this beta, try it, and report the issues you find. The release will be delayed until all reported issues with the beta are fixed.

If you have an ongoing data collection campaign, please do not install the beta and put your data at risk! Instead, set up a new instance on App Engine or try installing Aggregate on a local machine.

The important changes to verify in this release are:

If you have a bit more time, please also verify the other changes in the release notes. Again, this beta will ship in a week as a final release unless you report issues below.

Download beta

1 Like


What is the problem? Please be detailed.
I have created a form at ODK Aggregate instance but trying tu publish it to Google Spreadsheet gives some strange windows back instead of "Grant Access" page.

Clicking Publish:

What is this about? I have some doubts about applying the right role to the service account. Documentation just says select a role, but does not specify which one.

OK, after entering my gmail address I get a confirmation window:

I click OK and in a few seconds there is an error displayed:

I feel like I'm missing something obvious.

What ODK tool and version are you using? And on what device and operating system version?

  • ODK Aggregate v1.6.0-beta.0

    • Installed using ODK-Aggregate-v1.6.0-beta.0-Windows.exe
    • Installed it to Google App Engine
    • Followed this instructions for installation
    • Followed this instructions to set up OAuth access to Google APIs
  • ODK Collect v1.15.1

    • No issue related to publishing here: I have successfully got a form from ODK Aggregate, filled it and sent it.

What steps can we take to reproduce the problem?
Not sure, I've just followed the instructions.

Tried roles for the service account: Project -> Editor and Datastore -> cloud Database User.

What you have you tried to fix the problem?
Different roles for the service account, reinstalling ODK Aggregate, different google accounts, tried everything on freshly created google account.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

I can provide access to ODK Aggregate instance, App Engine and tmp google account where this behaviour is reproduced.

Thank you in advance.

Thanks for trying out the Aggregate 1.6.0 beta, @TV_Smirnov! The issue is being tracked at https://github.com/opendatakit/aggregate/issues/265 though we have trouble reproducing it consistently. @ggalmazor will likely get in touch to get some of the information you've offered.

Did you update from the stable 1.5.0 version? Did you try publishing to spreadsheets from that version and if so, did it work?

  1. It was not an upgrade, I installed it from scratch.
  2. Same issue with Spreadsheets.

Thanks for the extra info!

Do you mean with 1.5.0? If so, that is very interesting and makes me wonder whether something could have change on AppEngine's or Google Drive's end.

I just learned about ODK and tried what was the latest - 1.6.0.

I haven't touched stable 1.5.0 yet. But will try that.

Thanks for the feedback, @TV_Smirnov!

Hi, @TV_Smirnov!

Today we have merged a PR that solves the issue you're having. We hope to release a new version soon with this and other fixes. I'll post a comment when it's ready.

1 Like