ODK Briefcase error while pulling from Collect directory

1. What is the problem? Be very detailed.
Hi, I created a form by excel and used the odk xlsform tool to convert it to xml and pasted the file in my phone. I do not wish to operate the whole thing through a server and want to keep it all offline. The form opens just fine on my phone and I am able to fill it out without any issues. I then saved a copy of the folder from my phone to my desktop and am trying to pull the form to briefcase. The form shows up in the list of form names but when I click pull. The status indicates "Failed". I looked through the details and it says
"resolving against briefcase form definitions
unable to copy form definition and/or media folder: Form definitions are incompatible.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK collect v 1.24.1 on android one device
ODK Briefcase v 1.17.1 on windows 10 desktop

3. What you have you tried to fix the problem?
I assumed there could be a problem with my form while creating it so I created a new form and filled again and resubmitted but the error persists. Not sure what else I can do.

4. What steps can we take to reproduce the problem?
Not sure

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @orvill,

Can you look for the briefcase log file and share it here? You should find it in the same location with the briefcase jar file.

Also, can you share your form?

briefcase.zip (2.8 KB) Hi dicksonsamwel, im uploading a .zip file with the .log file and form .xml.

Can you share a copy of the odk folder from the device? Share it as it is.

Hi, @orvill!

I've taken a look to the problem but I can't be sure of what's exactly happening because Briefcase currently masks the real cause of the error you're getting. I've built a modified version that won't do this and will let us see the cause in the logs. Could you give it a try, please?

Get it here: briefcase_i834.zip

I'm really sorry for the late response. I've gone ahead and collected the data using the same form I created, however I cannot share the odk folder with the data. @dicksonsamwel I'm sharing a folder with just 1 form filled in with random text just for the sake of it and I hope this will do.odk.zip (2.4 MB)

@ggalmazor I tried using the briefcase file you sent me but that too shows the same error.

1 Like

Thanks, @orvill!

I tried using the briefcase file you sent me but that too shows the same error.

Yes, that was expected, although the version I attached would produce more information for me to track down the cause of the bug. Ideally, you would run it, get the error, and attach the log file again. Could you do that?

In the meantime, I'll try with the form and submission you've sent.

I've tried the form you've attached and I got to pull it without any errors. I see that Briefcase is failing to export it though. I'm studying this, but it looks like a different problem than the one you've reported.

I've created issue #841 to track the error I've found when exporting the form.

As soon as I can get my hands on the new briefcase log file from @orvill, I'll continue studying this.

Sorry for getting back on this after more than a year.
I was running out of time so i gave up on that form and created a new one and the new one ran fine.
I recently created a different form for data collection which would happen on a bigger scale and ran into the same issue again, however since i had also shared the .xml, when it was created, to a bunch of people, a colleague of mine did a test run with it at the same time as i did, and she was able to export the data without any issue. So, i just downloaded briefcase again, gave it a different storage folder and everything ran fine.
I had to get back to this post as soon as i found out. It might not be an actual solution, but i guess you could call it one.

1 Like