ODK Briefcase not running with JDK 9

What is the problem? Please be detailed.
I couldn't start operation of ODK Briefcase. Every time I try to open ODK Briefcase, "The Java JAR file "ODK Briefcase v1.8.0 Production.jar" could not be launched." shows up. I have no idea what is going on. I downloaded JDK 9 to operate ODK Briefcase, but it seems this is not working properly.

I would like to ask you to how I can solve this problem? I am using mac os.

What ODK tool and version are you using? And on what device and operating system version?
ODK Briefcase and JDK 9

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hello, you should try to see if your java is working well, go to command line and verify it. I'm not a Mac user but try
This opens a command-line t and type 'java -version' at the prompt (without quotes) you should see something like:

java version "X.X.X_X"
Java(TM) SE Runtime Environment (build X.X.X_X Y).

If it doesn't work, you may need to set up you environment path by looking here or searching in Google.


@Musashi_Fujimura Can you try uninstalling Java 9 and installing Java 8 and see if that works?

1 Like

Thank you very much for your advice. I have been trying, but it seems the JDK 9 doesn't work on my computer...

Thank you so much for your reply. Can I ask you how to uninstall? Actually I don't use programming applications at all and don't know even how to uninstall... Thank you in advance.

Ways to unsinatll Java or any software from a computer machine is :
From Mac : https://www.wikihow.com/Uninstall-Programs-on-Mac-Computers
From Microsoft : https://support.microsoft.com/en-us/help/2601726
From Linux : https://www.howtogeek.com/229699/how-to-uninstall-software-using-the-command-line-in-linux/

In winodws computer if you want to uninstall press (Windows Key + r ) at same time then type appwiz.cpl in run box and click on OK. You will see control panel there. And then you can uninstall software from control panel.

After uninstalling Java you need to restart your computer it doesn't matter that which OS(Windows / Linux / Mac) are you using, You need to restart your computer.

Then install Java 8 which is stable for ODK from below link


Thank you for your advice! I made it to operate ODK finally!!!! Tons of millions of thanks!


Thank you finally I solved it! huge appreciations!

Thank you! I finally solved it :)!