ODK Briefcase SLF4J command line error

What is the problem? Please be detailed.
When calling ODK Briefcase from mac osx high sierra terminal using the following commands:

java -jar "ODK Briefcase v1.8.0 Production.jar" --form_id market_prices --storage_directory ~/Desktop --aggregate_url https://my_server.appspot.com --odk_username my_username --odk_password my_password

(but with my own server url and login details) I get the following error message:

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.

and I'm unable to download or export data.

However, briefcase with the GUI works fine.

Any thoughts would be appreciated.

What ODK tool and version are you using? And on what device and operating system version?
ODK Briefcase v1.8.0 Production.jar
macOS High Sierra 10.13
java version "1.8.0_152"
Java(TM) SE Runtime Environment (build 1.8.0_152-b16)
Java HotSpot(TM) 64-Bit Server VM (build 25.152-b16, mixed mode)

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?
Updated to version 9 of Java, then reverted back to 8, still no joy.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Thanks for including all that detailed troubleshooting information.

That SLF4J message should just be a warning and should not interfere with tool functionality. Unfortunately, it does prevent logging from happening and means there's no output from the command line mode. Could you please double check whether perhaps the download and export are working, just not providing any feedback?

I didn't realize this problem had made it into production. It has been fixed on the developer build and we should release an update sooner than later.