Odk central in raspberry

1. What is the problem? Be very detailed.
ODK Central in not install/support in raspberry pi4
2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Central in Raspbian Buster Lite Release 2019-09-26

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?
run "docker-compose build" and in the step 10 of nginx.dockerfile "RUN apt-get update; apt-get install -y openssl netcat nginx-extras lua-zlib" crash
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

WE have this error:
standard_init_linux.go:211: exec user process caused "exec format error"
ERROR: Service 'nginx' failed to build: The command '/bin/sh -c apt-get update; RUN apt-get install -y openssl netcat nginx-extras lua-zlib' returned a non-zero code: 1

hi @ortack, did you make any progress on this
i'm also trying to install Central on a raspberry pi
running Ubuntu 20.04 LTS (GNU/Linux 5.4.0-1012-raspi aarch64)
hitting the same error message

searching i found an issue on a different software that notes

This is definitely caused by your target runtime platform (ARM). This is probably built for X86_64 platform.

Nginx can run on the Pi? Because after sudo apt-get install nginx the following works:

$ nginx -v
nginx version: nginx/1.18.0 (Ubuntu)

and also i can run nginx with docker on the pi

$ docker pull nginx
Using default tag: latest
latest: Pulling from library/nginx
33cc09c9b190: Pull complete 
b6db46e5e452: Pull complete 
31f3e6b96caf: Pull complete 
79409b429d69: Pull complete 
fb76351c1fc0: Pull complete 
Digest: sha256:21f32f6c08406306d822a0e6e8b7dc81f53f336570e852e25fbe1e3e3d0d0133
Status: Downloaded newer image for nginx:latest

$ docker run --name testing-nginx -p 8080:80 nginx
/docker-entrypoint.sh: /docker-entrypoint.d/ is not empty, will attempt to perform configuration
/docker-entrypoint.sh: Looking for shell scripts in /docker-entrypoint.d/
/docker-entrypoint.sh: Launching /docker-entrypoint.d/10-listen-on-ipv6-by-default.sh
10-listen-on-ipv6-by-default.sh: Getting the checksum of /etc/nginx/conf.d/default.conf
10-listen-on-ipv6-by-default.sh: Enabled listen on IPv6 in /etc/nginx/conf.d/default.conf
/docker-entrypoint.sh: Launching /docker-entrypoint.d/20-envsubst-on-templates.sh
/docker-entrypoint.sh: Configuration complete; ready for start up