ODK Central upgrade fails when restarting server

What is the issue?
We have a Digital Ocean droplet running ODK Central. When running through the steps to upgrade to Central v2023.2 everything goes well until we get to Step 10 Restart the server. I type in docker compose up -d as instructed and after running for 20 minutes or so the process terminates with the message New patch version of npm available! 10.2.3 -> 10.2.5.

Here are the last few lines from the output:

 => ERROR [nginx intermediate 5/5] RUN OIDC_ENABLED="false" files/prebuild/build-frontend.sh                    1896.6s
------                                                                                                                  
 > [nginx intermediate 5/5] RUN OIDC_ENABLED="false" files/prebuild/build-frontend.sh:                                  
33.95 npm WARN deprecated stable@0.1.8: Modern JS already guarantees Array#sort() is a stable sort, so this library is deprecated. See the compatibility table on MDN: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/sort#browser_compatibility                                                                                
53.46                                                                                                                   
53.46 added 1089 packages in 52s
54.75 
54.75 > odk-central-frontend@0.1.0 build
54.75 > vue-cli-service build
54.75 
56.28 All browser targets in the browserslist configuration have supported ES module.
56.28 Therefore we don't build two separate bundles for differential loading.
56.28 
56.36 
56.36 -  Building for production...
1896.2 Killed
1896.3 npm notice 
1896.3 npm notice New patch version of npm available! 10.2.3 -> 10.2.5
1896.3 npm notice Changelog: <https://github.com/npm/cli/releases/tag/v10.2.5>
1896.3 npm notice Run `npm install -g npm@10.2.5` to update!
1896.3 npm notice 
------
failed to solve: process "/bin/sh -c OIDC_ENABLED=\"$OIDC_ENABLED\" files/prebuild/build-frontend.sh" did not complete successfully: exit code: 137

What have you tried to fix the issue?

I have run the command npm install -g npm@10.2.5 as suggested in the script output but that doesn't work as I don't have npm installed.

I have also restarted the upgrade process afresh but it always bombs out at the same place. I've tried three times.

What can I do to solve this issue?

Many thanks, Frank.

The npm version isn't the issue. The build process is being killed so it's likely a resource (usually RAM) issue.

What Central version are you upgrading from? How much RAM does your server have? Is your CPU being maxed out?

Hi,
Thanks for the tip. We have 1Gb RAM but I'll increase that and try again.
We are upgrading from Central 1.1 so it is a fairly old version.
Frank.

A post was split to a new topic: Error upgrading from 1.5.1

Hi. Your suggestion about RAM being the issue was correct. Our Digital Ocean droplet only had 1 GB RAM so I doubled it to 2 GB and have been able to complete the upgrade. Thanks for the help.

1 Like