ODK Change Language Option Unavailable on Tablet

Hi ODK Community,

I am trying to get our translations to a survey to work on tablets in
multiple countries. The survey works in French (i.e. the translations have
been programmed into the .xml file) as it has been tested on another
tablet, however when our collaborators try to change the language on their
tablet (ODK Collect version 1.4.10), in the menu bar within a form they do
not have the "Change Language" option, they only have the "General
Settings" option.

Any help would be appreciated.

Thank you in advance,
Russanthy

The menu within the form is only shown if the form (XML file) has multiple
language translations within it. This is why these options are only
available after opening a form -- ODK Collect needs to examine the form to
see whether there are multiple languages defined, and then show or hide the
change-language option accordingly.

It is likely that their form lacks anything other than the default
language. If this is the form you have been working with that has french
translations, be sure that they have updated to the most recent version of
the form on their ODK Aggregate server and that they have pulled that
definition down to their device (via Get Blank Form). It may be that they
have an older version with just the default language.

··· On Fri, Sep 9, 2016 at 9:38 AM, Russanthy Velummailum wrote:

Hi ODK Community,

I am trying to get our translations to a survey to work on tablets in
multiple countries. The survey works in French (i.e. the translations have
been programmed into the .xml file) as it has been tested on another
tablet, however when our collaborators try to change the language on their
tablet (ODK Collect version 1.4.10), in the menu bar within a form they do
not have the "Change Language" option, they only have the "General
Settings" option.

Any help would be appreciated.

Thank you in advance,
Russanthy

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks very much for your response, Mitch.

It turned out to be a glitch in the software because when they had
uninstalled, re-installed ODK collect and uploaded the same forms
everything worked fine.

Russanthy

··· On Tue, Sep 13, 2016 at 1:22 PM, Mitch Sundt wrote:

The menu within the form is only shown if the form (XML file) has multiple
language translations within it. This is why these options are only
available after opening a form -- ODK Collect needs to examine the form to
see whether there are multiple languages defined, and then show or hide the
change-language option accordingly.

It is likely that their form lacks anything other than the default
language. If this is the form you have been working with that has french
translations, be sure that they have updated to the most recent version of
the form on their ODK Aggregate server and that they have pulled that
definition down to their device (via Get Blank Form). It may be that they
have an older version with just the default language.

On Fri, Sep 9, 2016 at 9:38 AM, Russanthy Velummailum <russanthy@gmail.com wrote:

Hi ODK Community,

I am trying to get our translations to a survey to work on tablets in
multiple countries. The survey works in French (i.e. the translations have
been programmed into the .xml file) as it has been tested on another
tablet, however when our collaborators try to change the language on their
tablet (ODK Collect version 1.4.10), in the menu bar within a form they do
not have the "Change Language" option, they only have the "General
Settings" option.

Any help would be appreciated.

Thank you in advance,
Russanthy

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to a topic in the
Google Groups "ODK Community" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/opendatakit/IZPzIjC9Xj4/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Russanthy Velummailum, MSc (Physiology), MPH (Epidemiology)

Research Analyst | Centre for Global Child Health

Peter Gilgan Centre For Research and Learning | The Hospital for Sick
Children

686 Bay Street, Toronto, Ontario M5G 0A4 Suite 11.9805

416 813 7654 ext. 309511