ODK Collect shows big numbers in exponential notation when editing the data

Hi,

I have an ODK form that collects a big number, for example 2,000,000. We
define such variable as decimal type. If we collect such number with
Collect, save the form and come back to it Collect shows it as 2.0E6 . How
can I correct this?

Dear QLands,

Use data type 'text' then under the column 'appearance' put 'numbers'.

That should fix it.

Collins

··· On Tue, Feb 2, 2016 at 8:15 PM, QLands Software wrote:

Hi,

I have an ODK form that collects a big number, for example 2,000,000. We
define such variable as decimal type. If we collect such number with
Collect, save the form and come back to it Collect shows it as 2.0E6 . How
can I correct this?

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

And note that this will store the number as a text string.
And it will not necessarily ensure that the text string is a valid number
(e.g., "0.0.0" would be allowed).
You would have to set up a regex() constraint to ensure that it is
well-formed.

If you subsequently need to interpret the value as a number, you would need
to convert it to a number using the number() function:

number(${fieldname})

··· On Tue, Feb 2, 2016 at 9:58 PM, Collins O. Adoyo wrote:

Dear QLands,

Use data type 'text' then under the column 'appearance' put 'numbers'.

That should fix it.

Collins

On Tue, Feb 2, 2016 at 8:15 PM, QLands Software <qlands.software@gmail.com wrote:

Hi,

I have an ODK form that collects a big number, for example 2,000,000. We
define such variable as decimal type. If we collect such number with
Collect, save the form and come back to it Collect shows it as 2.0E6 . How
can I correct this?

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

I did this, which works fine for keeping the number syntax correct in the
saved form, but does not bring up numeric pad for number entry (instead,
brings up full keyboard).

<bind nodeset="/data/contact_number" type="text"/>            

<input ref="/data/contact_number" appearance="numbers">
  <label ref="jr:itext('/data/contact_number:label')"/>
</input>

Any idea how to fix this?

··· On Wednesday, 3 February 2016 10:58:57 UTC+5, Collins McAdoyo wrote: > > Dear QLands, > > Use data type 'text' then under the column 'appearance' put 'numbers'. > > That should fix it. > > Collins > > On Tue, Feb 2, 2016 at 8:15 PM, QLands Software <qlands....@gmail.com > wrote: > >> Hi, >> >> I have an ODK form that collects a big number, for example 2,000,000. We >> define such variable as decimal type. If we collect such number with >> Collect, save the form and come back to it Collect shows it as 2.0E6 . How >> can I correct this? >> >> -- >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> >> --- >> You received this message because you are subscribed to the Google Groups >> "ODK Community" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to opendatakit...@googlegroups.com . >> For more options, visit https://groups.google.com/d/optout. >> > >

Try a different device keyboard. Or look at the settings available for the
device keyboard.

We use the standard mechanisms to request a numeric entry keyboard. If the
device keyboard that your device uses does not recognize and respond to
that request, then the full keyboard will be displayed.

··· On Tue, May 24, 2016 at 2:14 AM, Saad wrote:

I did this, which works fine for keeping the number syntax correct in the
saved form, but does not bring up numeric pad for number entry (instead,
brings up full keyboard).

<bind nodeset="/data/contact_number" type="text"/>

<input ref="/data/contact_number" appearance="numbers">
  <label ref="jr:itext('/data/contact_number:label')"/>
</input>

Any idea how to fix this?

On Wednesday, 3 February 2016 10:58:57 UTC+5, Collins McAdoyo wrote:

Dear QLands,

Use data type 'text' then under the column 'appearance' put 'numbers'.

That should fix it.

Collins

On Tue, Feb 2, 2016 at 8:15 PM, QLands Software qlands....@gmail.com wrote:

Hi,

I have an ODK form that collects a big number, for example 2,000,000. We
define such variable as decimal type. If we collect such number with
Collect, save the form and come back to it Collect shows it as 2.0E6 . How
can I correct this?

--

Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google
Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to opendatakit...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups
"ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com