ODK Collect - Uploading results - 404

Hi guys,

I'm new to ODK and so far I've succesfully setup ODK Aggregate on the Google Cloud Platform, created a form with ODK Build, managed to import it into ODK Collect and sent it to Aggregate. Splendid!

Now, I'm trying to setup ODK Collect to send the results to Google Sheets and followed all these steps:

I managed to validate the .XML and placed in on Google Drive. I double checked the submission URL to my Google Sheet, and created an empty tab "results". I made sure the sheet was shared with my ODK Collect Google Account with Editing rights. But when I finalize my form on ODK Collect and send it, I get an error saying:


I'm sure some of you may know what is happening here!
Thank you :slight_smile:

1 Like

I think I found the issue; there was a typo. Forgot to use a " _ " in one of the columns.
I compared the demo Google Sheet with my own, and that was the only thing I found to be different. Mind the typos! :slight_smile: All working now!

1 Like

Dear Philippe,
I have the same issue currently.

Try your solution, but still not working :disappointed_relieved:
Any help please!
Thanks. Andre

I have the same problem. Any solution?

Hi @philippevg , I had the same problem trying to send the results to google sheets... and i found that you need create the sheet directly on google drive and not create and paste on drive a xls sheet since your computer. It works for me, i hope it can help you.

I was using google spreadsheet as a server and was uploading a url using (right click) "get shareable link" function and inserting this link in appropriate place in the ODK build. This was giving me the 404 error. Then, after a number of tests, I found that the "get shareable link" it is not the same as actually opening the spreadsheet and checking your url in your browser. So, what I did, I copied the url from the browser (rather than using shareable link function) and everything started to work. Hope this will help others.

1 Like

@empirica Thanks for the tip! I'm sure it will help those landing on this topic.
I've been using ODK successfully now for almost 2 years.

For those experiencing a 404 I can say:

  1. Check if you've pasted the correct URL in your 'settings' tab and use the URL from your address bar, not the "Shareable link".
  2. Check that your columns don't have any spaces in their naming.
    For example, on the 'settings' tab use:
  • form_title
  • form_id
  • submission_url
  • default_language
  1. Don't create any columns on the 'results' tab. Let ODK generate the columns on your first submission.

  2. Be sure the ODK collect user has permission to the sheet (check the 'Sharing' options).

Any errors in question types or item naming will be given when you download your sheet as XLS and convert into an XML using the Online XLSForm converter or the Offline XLSForm.


this worked for me as well. thanks

1 Like