ODK tools v1.4.6 now available for download

The v.1.4.6 updates are now available for:

  • Collect
  • xlsform.exe (and XLSForm webpage)
  • Validate
  • Briefcase
  • FormUploader
  • Aggregate (use 1.4.6 or greater)

The new version of ODK Collect will commence rolling out on the Google Play
store shortly.

NOTE: To use the new OpenStreetMap feature, you must upgrade all of these
tools!

The ODK Collect 1.4.6 release has:

  • OpenStreetMap integration using OpenMapKit on Android. See
    documentation here
    https://opendatakit.org/help/form-design/open-street-map/ (requires
    Aggregate 1.4.6 or above).
  • new language support (Afrikaans) and updates to other languages.
    Arabic is also present but may have issues. If you see problems with the
    translations, please join the ODK Collect project at Transifex and correct
    the translations https://www.transifex.com/opendatakit/odk-collect/
  • fix UTF-8 corruption issue when saving and re-loading instance data.
  • downloads page now automatically selects the out-of-date forms.
  • display error messages if URL, username or password contain leading or
    trailing whitespace
  • remove graphics metadata that was causing APK packaging warnings
  • converted to AndroidStudio project

Release notes are here:

Briefcase and Validate now require Java 1.7

The XlsForm webpage and xlsform.exe now use Python 2.7

··· -- Mitch Sundt Software Engineer University of Washington mitchellsundt@gmail.com

Release notes have been moved to


(removed the extra -- between Collect and Release)

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Wed, Aug 26, 2015 at 4:01 PM, Mitch Sundt mitchellsundt@gmail.com wrote:

The v.1.4.6 updates are now available for:

Collect
xlsform.exe (and XLSForm webpage)
Validate
Briefcase
FormUploader
Aggregate (use 1.4.6 or greater)

The new version of ODK Collect will commence rolling out on the Google Play
store shortly.

NOTE: To use the new OpenStreetMap feature, you must upgrade all of these
tools!

The ODK Collect 1.4.6 release has:

OpenStreetMap integration using OpenMapKit on Android. See documentation
here https://opendatakit.org/help/form-design/open-street-map/ (requires
Aggregate 1.4.6 or above).
new language support (Afrikaans) and updates to other languages. Arabic is
also present but may have issues. If you see problems with the
translations, please join the ODK Collect project at Transifex and correct
the translations https://www.transifex.com/opendatakit/odk-collect/
fix UTF-8 corruption issue when saving and re-loading instance data.
downloads page now automatically selects the out-of-date forms.
display error messages if URL, username or password contain leading or
trailing whitespace
remove graphics metadata that was causing APK packaging warnings
converted to AndroidStudio project

Release notes are here:
https://github.com/opendatakit/opendatakit/wiki/Collect---Release-Notes

Briefcase and Validate now require Java 1.7

The XlsForm webpage and xlsform.exe now use Python 2.7

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Where is the source code for ODK collect version 1.4.6 . Please share the link.

··· On Thursday, August 27, 2015 at 1:31:17 AM UTC+5:30, Mitch Sundt wrote: > The v.1.4.6 updates are now available for: > Collectxlsform.exe (and XLSForm webpage)ValidateBriefcaseFormUploaderAggregate (use 1.4.6 or greater) > > The new version of ODK Collect will commence rolling out on the Google Play store shortly. > > > NOTE: To use the new OpenStreetMap feature, you must upgrade all of these tools! > The ODK Collect 1.4.6 release has: > OpenStreetMap integration using OpenMapKit on Android. See documentation here https://opendatakit.org/help/form-design/open-street-map/ (requires Aggregate 1.4.6 or above).new language support (Afrikaans) and updates to other languages. Arabic is also present but may have issues. If you see problems with the translations, please join the ODK Collect project at Transifex and correct the translations https://www.transifex.com/opendatakit/odk-collect/ > fix UTF-8 corruption issue when saving and re-loading instance data. > downloads page now automatically selects the out-of-date forms. > display error messages if URL, username or password contain leading or trailing whitespaceremove graphics metadata that was causing APK packaging warningsconverted to AndroidStudio project > > Release notes are here: https://github.com/opendatakit/opendatakit/wiki/Collect---Release-Notes > > > Briefcase and Validate now require Java 1.7 > > > The XlsForm webpage and xlsform.exe now use Python 2.7 > > > -- > > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com

All ODK source code is at http://github.com/opendatakit

Yaw

··· -- Need ODK services? http://nafundi.com provides form design, server setup, professional support, and software development for ODK.

On Tue, Sep 1, 2015 at 8:03 AM, debashish@sdrc.co.in wrote:

Where is the source code for ODK collect version 1.4.6 . Please share the link.
On Thursday, August 27, 2015 at 1:31:17 AM UTC+5:30, Mitch Sundt wrote:

The v.1.4.6 updates are now available for:
Collectxlsform.exe (and XLSForm webpage)ValidateBriefcaseFormUploaderAggregate (use 1.4.6 or greater)

The new version of ODK Collect will commence rolling out on the Google Play store shortly.

NOTE: To use the new OpenStreetMap feature, you must upgrade all of these tools!
The ODK Collect 1.4.6 release has:
OpenStreetMap integration using OpenMapKit on Android. See documentation here https://opendatakit.org/help/form-design/open-street-map/ (requires Aggregate 1.4.6 or above).new language support (Afrikaans) and updates to other languages. Arabic is also present but may have issues. If you see problems with the translations, please join the ODK Collect project at Transifex and correct the translations https://www.transifex.com/opendatakit/odk-collect/
fix UTF-8 corruption issue when saving and re-loading instance data.
downloads page now automatically selects the out-of-date forms.
display error messages if URL, username or password contain leading or trailing whitespaceremove graphics metadata that was causing APK packaging warningsconverted to AndroidStudio project

Release notes are here: https://github.com/opendatakit/opendatakit/wiki/Collect---Release-Notes

Briefcase and Validate now require Java 1.7

The XlsForm webpage and xlsform.exe now use Python 2.7

--

Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--

Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en


You received this message because you are subscribed to the Google Groups "ODK Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email to opendatakit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.