ODK VM from Gumroad - out of date & hard to use

Today I downloaded and tried to import the gumroot ODK VM "OVF" template (version in to my Vmware ESXi / vSphere 6.5 environment and got the following error message:

Issues detected with selected template: Details: --1::-1:VALUE_ILLEGAL: No supported hardware version among [vmx-06]; supported: [vmx-04, vmx-07, vmx-08, vmx-09, vmx-10]

during step #3 of the OVF template import "Validating"

I tried importing on both an ESXi 6.5 and and ESXi 5.5 system and got the same error.

Then i went and just created a new virtual machine (you will want Ubuntu 12.04, 32-bit)
and imported just the vmdk file (you can "7zip" extract the vmdk file from the .OVF template file which is basically a zip file)

But ubuntu 12.04 is really old at this point... does anyone know of a newer Virtual Machine image for the ODK server on a modern platform such as CentOS7, Debian 9, or Ubuntu 16.04 LTS ?


Hi @mbw! The VM is out-of-date because the infrastructure that I used to build it is deprecated and it's been hard for me to find the time required to find reasonable alternatives. Since you have a CS background, would you be willing to help with this effort?

Mr. Anokwa,

thanks for the reply :wink:

Im in the process of building a vm image using the latest Debian 9

It looks like you also have been working on a Docker container version
of the ODK aggregate also - can you tell me a little about

what the state of that is?



@mbw We just shipped ODK Aggregate v1.5 Beta with more modern VM (Debian 9, Tomcat 8, PostgreSQL 9.6). Can you try it on your VMWare ESXi / vSphere 6.5 environment and see if it works for you?