ODK XLsForm Appearance search('EPIDATA') not working in new version of ODK-Collect

What is the problem? Please be detailed.
Search function is not working using Appearance e.g. search('EPIDATA') after updating from ODK Collect v1.16.4 to ODK Collect v1.17.2. I design my form using XLSForm. It worked with ODK Collect v1.16.4
What ODK tool and version are you using? And on what device and operating system version?
I am using ODK Collect v1.17.2 on Sumsung galaxy Tab A (2016). Andriod 7.0. I tried it on other device and yield the same outcome
What steps can we take to reproduce the problem?
I new ODK Collect version to fix the bug
What you have you tried to fix the problem?
Revert to ODK Collect v1.16.4
Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
Link to screenshot: ODK Collect v1.16.4 (https://drive.google.com/file/d/1ana7OjxUdN1x0eB3lJRJNJHnA1VW37q6/view?usp=sharing)
ODK Collect v1.17.2 (https://drive.google.com/open?id=1F_r0SjlO8vtso1AcB-Z8ksgFL-0esbk8)

I can't see your second screenshot but I'm guessing that you would like for it to include a search box that users can type filter text into, is that correct?

The search() appearance/function is meant just to pull records from a CSV. It was unintentional that search() started showing that search box when the (different) search appearance was introduced. If you would like to combine them, you can use search search().

In general, I invite you to follow the releases category so you can see when new versions come out and try them out in beta to make sure they work for you. In fact, there's a beta out now.

Thank you Hélène for the response. I use the search() appearance/function to pull records from csv file name EPIDATA. I did not mention that apology. I will try using search search() by updating my XLSForm. I will try out the beta version too.

1 Like

It worked !. Thank you

1 Like