PEM key generation

What is the problem? Please be detailed.
How to generate private key for ODK briefcase
What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

See the docs here:

i have tried running these commands but it is gives this error openssl : The term 'openssl' is not recognized as the name of a cmdlet, function, script file, or operable program.
Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1

  • openssl genpkey -out MyPrivateKey.pem -outform PEM -algorithm RSA -pk ...
  •   + CategoryInfo          : ObjectNotFound: (openssl:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException

Hi, @Vineet_Jk!

It seems like you're running that on Windows. Did you install OpenSSL? There's a section explaining how to do that in the link @yanokwa has shared:

1 Like