Preview has not finished processing for this Form

1. What is the issue? Please be detailed.
Fresh installation of ODK version v2023.1.0-2-g894dc61 on Ubuntu 22.04.1 using the guide provided. I only changed the env, the SMTP mail provider in files/service, persisted the postgres volume in docker-compose.yml and put customssl certificates in files/local/customssl. Everything went very well and the service started and runs as expected. However once I upload a Form the preview never becomes available (ever - even after a few days).
Docker logs does not show any issues or errors.

2. What steps can we take to reproduce this issue?
As above.

3. What have you tried to fix the issue?
Completely removed the installation and started from scratch a couple of times.

4. Upload any forms or screenshots you can share publicly below.

Try a docker-compose restart and see if that helps render the previews. My guess is no.

I think the likely reason isn't not working is that the service container can't talk to the enketo container. Do you have an on-machine firewall? Try turning it off to see if it helps.

You can also try adding upstream DNS servers to Docker.

Thank you for the reply. I do not have an on machine firewall. I have connected to the enketo container and ran the curl command as in the documentation and this works well. I have also tried the docker compose restart and it didn't help. I will try the DNS server link you suggested.

I have done some further troubleshooting and found the following:
from the central_enketo container:
telnet localhost 8005 works well
telnet with FQDN 8005 gets connection refused
from the central service container
telnet localhost and FQDN 8005 gets connection refused
looks like the enketo is not binding to the external IP interface

from the central_service container
curl http://enketo:8005 does connect successfully
telnet enketo 8005 does get a connection

Thank you I have solved the problem. The issue was with the DOMAIN variable in .env.