Problem in connecting while pushing data

What is the problem?
I have problem in connecting in the Push tab. it gives the following message

Starting url: unexpected exception:
Starting url: unexpected exception:
Starting url: unexpected redirection
attempt to a different host: http://localhost/formUpload

I have used the same username and password to login for pulling data

What ODK tool and version are you using? And on what device and operating system version?
I am using ODK Briefcase V1.4.10 and ODK Aggregate V1.4.15

What steps can we take to reproduce the problem?
I downloaded data using Pull and tried loging for Push but didnt work

What you have you tried to fix the problem?
I have reinstalled Tomcat

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi there! The push functionality is for downloading data from one ODK server and pushing it to another ODK server. Is that what you are trying to do?

Hi Anokwa,

I am downloading from and uploading to the same server. I have worked with ODK Briefcase a lot but this is the first time i am facing this problem.


It doesn't make sense that you would pull data from a server and then push that same data to the same server. Am I misunderstanding?

Regardless, it sounds like this used to work and now it doesn't. What has changed since it worked?

I was doing it for installing the updates. I reinstalled the Tomcat and ODK Aggregate and it worked.