Problem with JavaRosa Parsing Form: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?

1. What is the problem? Be very detailed.
Hope you can help me!
I am having problems to add a new form into my odk aggregate. I continue receiving the Error message. I read similar posts about the topic but I can't solve my problem yet. I also checked for possible error, fixed some issues, tried to delete some cells that "might be the problem" but nothing worked. I hope you can help me with this!

2. What app or server are you using and on what device and operating system? Include version numbers.
app: ODK collect v1.22.4 device: Galaxy Tab S4, Operating system: android

3. What you have you tried to fix the problem?
Yes, reading old posts

4. What steps can we take to reproduce the problem?
Have a look at my XLSform

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
strong text test.xlsx (59.7 KB)

Hi @Ekatherina_Vasquez,

Can you provide more detail of the aggregate version and the xlsoffline converter that you are using?

Also can you try this converter

Hi Dickson!
I am using to check and convert my forms online, and according to this everything is fine.
for offline I tried with v1.10.0 but not luck either.

I've been able to reproduce this on an older Aggregate version. It does work on more recent versions of Aggregate. Do you know what version you are running?

When you say this is a new form, it's a form you've never used before, right? I think the problem is that you have a choice filter in a repeat which has only become supported recently. See trialid_manual=${trialid_manual}. That's a very useful thing to do but you'll need to update Aggregate to use it.