Repeat group variables not showing in aggregate

Hi all,

I need some help again. I am running a form with many variables packed into
a repeat group (household members). In Aggregate with previous forms I was
able to see a link an clicking on it opened this level. But with my current
form I only see the top level variables (also when exporting to csv and
publishing to google fusion tables).

Anyone have an idea what the issue might be?

Thanks

Olivier

The link should still be there with a "View" label that can be clicked to
open the repeat groups. E.g., the Miramare form on
https://opendatakit.appspot.com

If you can't see that with your data, then either your data has no repeat
groups, or something else is amiss.

The first thing to check is that the form used for data collection on your
phone is exactly the same form as was loaded on ODK Aggregate (i.e., delete
the form on the phone and download it from ODK Aggregate to the phone).
Then fill out that newly downloaded form and send it to ODK Aggregate. Does
the repeat group show for that newly completed survey?

If it doesn't, then send me the form.

Mitch

··· On Thu, Aug 30, 2012 at 3:21 AM, Olivier Kalmus wrote:

Hi all,

I need some help again. I am running a form with many variables packed
into a repeat group (household members). In Aggregate with previous forms I
was able to see a link an clicking on it opened this level. But with my
current form I only see the top level variables (also when exporting to csv
and publishing to google fusion tables).

Anyone have an idea what the issue might be?

Thanks

Olivier

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Hey Mitch,

thanks for your reply. I figured out the problem with my form. I have a
relevance attached to the groups that are supposed to be repeated, looking
like this:

With repeat being the group containing all the variables that should be
repeated if item is 1. It works just fine in Collect and the instance xml
from Collect contains all the answers, but then in Aggregate the "view"
link will not appear.

If I remove that binding and put the relevance in the bindings of all the
repeating variables the "add group" pop up will appear, even if item is not
equal to 1.

Did I do a mistake in my binding?

Thanks

Olivier

··· On Thursday, August 30, 2012 6:45:40 PM UTC+2, Mitch wrote: > > The link should still be there with a "View" label that can be clicked to > open the repeat groups. E.g., the Miramare form on > https://opendatakit.appspot.com > > If you can't see that with your data, then either your data has no repeat > groups, or something else is amiss. > > The first thing to check is that the form used for data collection on your > phone is exactly the same form as was loaded on ODK Aggregate (i.e., delete > the form on the phone and download it from ODK Aggregate to the phone). > Then fill out that newly downloaded form and send it to ODK Aggregate. Does > the repeat group show for that newly completed survey? > > If it doesn't, then send me the form. > > Mitch > > On Thu, Aug 30, 2012 at 3:21 AM, Olivier Kalmus <o.ka...@gmail.com wrote: > >> Hi all, >> >> I need some help again. I am running a form with many variables packed >> into a repeat group (household members). In Aggregate with previous forms I >> was able to see a link an clicking on it opened this level. But with my >> current form I only see the top level variables (also when exporting to csv >> and publishing to google fusion tables). >> >> Anyone have an idea what the issue might be? >> >> Thanks >> >> Olivier >> >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >

The repeat group should not have a type="string" assignment. It should not
have any type attribute at all.

Aggregate sees that it should be a "string" value and then ignores all the
nested data values within it.

You should just be able to do:

Mitch

··· On Thu, Sep 6, 2012 at 7:38 AM, Olivier Kalmus wrote:

Hey Mitch,

thanks for your reply. I figured out the problem with my form. I have a
relevance attached to the groups that are supposed to be repeated, looking
like this:

With repeat being the group containing all the variables that should be
repeated if item is 1. It works just fine in Collect and the instance xml
from Collect contains all the answers, but then in Aggregate the "view"
link will not appear.

If I remove that binding and put the relevance in the bindings of all the
repeating variables the "add group" pop up will appear, even if item is not
equal to 1.

Did I do a mistake in my binding?

Thanks

Olivier

On Thursday, August 30, 2012 6:45:40 PM UTC+2, Mitch wrote:

The link should still be there with a "View" label that can be clicked to
open the repeat groups. E.g., the Miramare form on
https://opendatakit.appspot.**com https://opendatakit.appspot.com

If you can't see that with your data, then either your data has no repeat
groups, or something else is amiss.

The first thing to check is that the form used for data collection on
your phone is exactly the same form as was loaded on ODK Aggregate (i.e.,
delete the form on the phone and download it from ODK Aggregate to the
phone). Then fill out that newly downloaded form and send it to ODK
Aggregate. Does the repeat group show for that newly completed survey?

If it doesn't, then send me the form.

Mitch

On Thu, Aug 30, 2012 at 3:21 AM, Olivier Kalmus o.ka...@gmail.comwrote:

Hi all,

I need some help again. I am running a form with many variables packed
into a repeat group (household members). In Aggregate with previous forms I
was able to see a link an clicking on it opened this level. But with my
current form I only see the top level variables (also when exporting to csv
and publishing to google fusion tables).

Anyone have an idea what the issue might be?

Thanks

Olivier

--
Post: opend...@googlegroups.com
Unsubscribe: opendatakit...@**googlegroups.com
Options: http://groups.google.com/**group/opendatakit?hl=enhttp://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer
University of Washington
mitche...@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com

Thanks Mitch,

works perfect now.

Olivier

··· On Thursday, September 6, 2012 6:19:15 PM UTC+2, Mitch wrote: > > The repeat group should not have a type="string" assignment. It should not > have any type attribute at all. > > Aggregate sees that it should be a "string" value and then ignores all the > nested data values within it. > > You should just be able to do: > > > > Mitch > > On Thu, Sep 6, 2012 at 7:38 AM, Olivier Kalmus <o.ka...@gmail.com wrote: > >> Hey Mitch, >> >> thanks for your reply. I figured out the problem with my form. I have a >> relevance attached to the groups that are supposed to be repeated, looking >> like this: >> >> >> >> With repeat being the group containing all the variables that should be >> repeated if item is 1. It works just fine in Collect and the instance xml >> from Collect contains all the answers, but then in Aggregate the "view" >> link will not appear. >> >> If I remove that binding and put the relevance in the bindings of all the >> repeating variables the "add group" pop up will appear, even if item is not >> equal to 1. >> >> Did I do a mistake in my binding? >> >> Thanks >> >> Olivier >> >> >> On Thursday, August 30, 2012 6:45:40 PM UTC+2, Mitch wrote: >> >>> The link should still be there with a "View" label that can be clicked >>> to open the repeat groups. E.g., the Miramare form on >>> https://opendatakit.appspot.**com >>> >>> If you can't see that with your data, then either your data has no >>> repeat groups, or something else is amiss. >>> >>> The first thing to check is that the form used for data collection on >>> your phone is exactly the same form as was loaded on ODK Aggregate (i.e., >>> delete the form on the phone and download it from ODK Aggregate to the >>> phone). Then fill out that newly downloaded form and send it to ODK >>> Aggregate. Does the repeat group show for that newly completed survey? >>> >>> If it doesn't, then send me the form. >>> >>> Mitch >>> >>> On Thu, Aug 30, 2012 at 3:21 AM, Olivier Kalmus wrote: >>> >>>> Hi all, >>>> >>>> I need some help again. I am running a form with many variables packed >>>> into a repeat group (household members). In Aggregate with previous forms I >>>> was able to see a link an clicking on it opened this level. But with my >>>> current form I only see the top level variables (also when exporting to csv >>>> and publishing to google fusion tables). >>>> >>>> Anyone have an idea what the issue might be? >>>> >>>> Thanks >>>> >>>> >>>> Olivier >>>> >>>> -- >>>> Post: opend...@googlegroups.com >>>> Unsubscribe: opendatakit...@**googlegroups.com >>>> Options: http://groups.google.com/**group/opendatakit?hl=en >>>> >>> >>> >>> >>> -- >>> Mitch Sundt >>> Software Engineer >>> University of Washington >>> mitche...@gmail.com >>> >> -- >> Post: opend...@googlegroups.com >> Unsubscribe: opendatakit...@googlegroups.com >> Options: http://groups.google.com/group/opendatakit?hl=en >> > > > > -- > Mitch Sundt > Software Engineer > University of Washington > mitche...@gmail.com >